Mini WILL NOT BOOT AT ALL after XP install disc boot

Discussion in 'macOS' started by grimmermatt, Apr 8, 2010.

  1. grimmermatt macrumors newbie

    Joined:
    Jun 1, 2009
    #1
    Any advice is much appreciated; I have looked everywhere.

    Chronology :
    - OSX was booting and working fine
    - inserted XP disc, realized I had data on that partition, aborted install at the "choose partition" screen
    - used business card trick to eject disc
    - put drive in external USB housing, works fine, OSX files look fine, transferred data
    - drive back into mini
    - NO BOOTABLE PARTITION FOUND
    - inserted XP disc --> same message
    - inserted SnowLeopard disc, flashing mac icon / circle-bar icon
    - key held while booting : x, c, option, Opt+Com+P+R (PRAM reset), Opt+Com+O+F (Open Firmware) --> no evidence the keyboard is even recognized
    - searched everywhere to no avail

    I AM SO CONFUSED.
     
  2. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #2
    What's the business card trick and why did you use it? Couldn't you have simply shut down the computer?
     
  3. grimmermatt thread starter macrumors newbie

    Joined:
    Jun 1, 2009
    #3
    If you reboot, it just goes back into the XP install process. Holding the eject key or mouse button on reboot didn't work. Inserting a folded-over business card to impede the disc tricks the machine into an ejection.
     
  4. marc.cizravi macrumors member

    Joined:
    Mar 8, 2010
    Location:
    Toronto, Ontario
    #4
    does your computer boot into target mode? holding T?

    do you have open firmware locked?
     
  5. grimmermatt thread starter macrumors newbie

    Joined:
    Jun 1, 2009
    #5
    Holding T at boot does nothing. The keyboard works; I am typing with it now. I have no idea what "open firmware locked" means.
     
  6. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #6
    Have you tried zapping the PRAM.
    Code:
    cmd+alt+P+R
    Edit: Yes you did, sorry.

    How about resetting the SMC? Unplug the mac mini from the mains, hold down the power button for at least 5 seconds, plug in and see how it goes.

    Just for future reference, you can choose boot without ejecting the XP cd by holding down alt when you turn it on.
     
  7. grimmermatt thread starter macrumors newbie

    Joined:
    Jun 1, 2009
    #8
    I tried everything recommended here, as well as here :
    http://www.123macmini.com/forums/viewtopic.php?p=187329#187329

    The only input I can tell is working (keyboard, mouse, anything) is the power button to turn it on. Holding the power button with the power disconnected did nothing. Taking the battery out and putting it back in did nothing. Booting with alt does nothing, just like every other key and key combo. The keyboard works on another computer. Anyone?
     
  8. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #9
    Have you tried booting off the OS X installation DVD and running Disk repair, or even backing up to another external drive and then reformatting?

    I'd wager the Windows install process did something to the boot sector of the drive and won't let you boot directly into OS X.
     
  9. grimmermatt thread starter macrumors newbie

    Joined:
    Jun 1, 2009
    #10
    As I said up top,
    - inserted Snow Leopard disc, flashing mac icon / circle-bar icon

    I can't boot at all from OSX on the HD, an OSX install disc, OSX on a USB HD, or an XP install disc. I have also tried every keyboard startup key and key combo I can find. Nothing has any effect. The machine doesn't even make the boot sound anymore.

    I would have reason to reformat if the Snow Leopard disc was recognized, began installation, and then told me I didn't have a partition with proper formatting. Someone suggested I need to dig up a Tiger installation disc. This seems hard to believe that a Snow Leopard disc will not do.

    I have also tried everything suggested here :
    http://www.123macmini.com/forums/viewtopic.php?p=187529#187529
     
  10. dnguyen macrumors regular

    Joined:
    Jun 9, 2008
    #11
    what service pack was the windows xp cd? If it was an old service pack you might have lost your os x partition. this happened to me.
     
  11. marc.cizravi macrumors member

    Joined:
    Mar 8, 2010
    Location:
    Toronto, Ontario
    #12
    It's got nothing to do with the installation at this point, it almost seems like something irreparable has been done and maybe you're having logic board issues at this point.

    If multiple functioning keyboards plugged into multiple functioning ports aren't letting you flush PRAM or giving you the boot options menu or booting into target mode, or single user mode, there's probably an issue with the logic board.

    Have you tried multiple ports? Do you know if your ports are all functioning?

    You've probably reached a dead end and at this point need a hardware repair, I don't see why NOTHING would be working unless there was some sort of physical malfunction
     
  12. grimmermatt thread starter macrumors newbie

    Joined:
    Jun 1, 2009
    #13
    I would tend to agree, but I can't believe that I have hardware issues that were caused by software (XP installation disc).
     
  13. max¥¥ macrumors 6502a

    Joined:
    Aug 7, 2008
    Location:
    Over there....
    #14
    just wondering did you ever flash the firmware, because i did on a G4 and it failed and for about 6 months i couldn't use open firmware, or hold down alt to select boot device or go into target disc mode by pressing T at boot, unfortunately i only no a fix if you can boot into mac osx
     
  14. marc.cizravi macrumors member

    Joined:
    Mar 8, 2010
    Location:
    Toronto, Ontario
    #15
    I had a client once install a firmware update that fried his logic-board. He said he didn't interrupt it, followed instructions exactly but the computer wouldn't accept a firmware restore and wouldn't complete the process. Apple said the mainboard had to be replaced. He lost his $2000+ 3 year 3 month old MBP because he ran software a software update, cool right? :]

    If you want to chalk it up to coincidence, you can... but it's quite possible you damaged something while you were removing/replacing the hard drive. Any shock/liquid/salt/foreign disturbance to the hardware and it's possible to do permanent damage... win some lose some :rolleyes:
     
  15. grimmermatt thread starter macrumors newbie

    Joined:
    Jun 1, 2009
    #16
    Thanks for the help, everyone, but I think it's time to cut my losses, junk the Mini, and start planning a cheap desktop Hackintosh.
     

Share This Page