Mini Won't Boot or Eject CD due to rEFIt - Help!

Discussion in 'Mac mini' started by BDPNA, Aug 20, 2009.

  1. BDPNA macrumors newbie

    Joined:
    Aug 20, 2009
    #1
    This is my fault, by the way, I admit that right up front.

    Long story short, I wanted my Mini to dual boot Ubuntu 9.04 and OSX, and the guides I was finding said to use rEFIt. This worked fine until I allowed Ubuntu to install a bunch of updates, which must have done something to my partition table, as now I can no longer boot OSX or Ubuntu, and the CD I stuck in there won't eject either (so I can't get my OSX install disc to even load).

    Can anyone help me out? Is there a rEFIt command from the shell I can run to eject the disc and try getting my OSX install disc in there?

    Really stuck - When I cold boot, rEFIt gives me choices of OSX or Ubuntu, both just spin and die during boot.

    Tried holding space bar, c key, option key, left mouse, all on cold boot and upon selecting OSX option from rEFIt menu, no luck getting disc to eject.

    I followed the guide here:

    http://blog.costan.us/2009/03/ubuntu-810-or-904-on-mac-mini.html

    Any help would be appreciated, I spent 2 hours trying to fix and I can't think of anything else to try...

    Did I do something wrong when I let Ubuntu 9.04 self-update? It REALLY seems to have screwed up my partition setup.
     
  2. QwertyPants macrumors newbie

    Joined:
    Aug 12, 2009
    Location:
    NYC
    #2
    possible remedy?

    -Something similar happened to me on my MBP not to long ago when i was trying to install ubuntu 8.10...the only way i managed to fix it was have my friend image his drive onto my WD passport 500 GB drive via Silverkeeper and i booted up and everything was fine and dandy from there.
    - When I started my mac up i just got the dreaded flashing folder i couldn't even install leopard, tiger, or ubuntu again. Hope that helps:confused:

    -When you press option does your computer see your hard drive?
     
  3. spacepower7 macrumors 68000

    Joined:
    May 6, 2004
    #3
    I had this problem

    I had this problem too. Sorry but I can't remember how I got the CD out (paperclip?), but I remember that after I did, I still couldn't boot into OSX. I tried multiple burned copies of 10.5.x The only solution was to use the 10.5.x Disc that came with the Mini that I had to dig out of storage.
     

Share This Page