"Mirroring" menu extra disappeared

Discussion in 'OS X Mountain Lion (10.8)' started by trondah, Jul 10, 2012.

  1. trondah macrumors 6502

    Joined:
    Dec 1, 2008
    #1
    I've been following developer seeds, and at some point the "Mirroring" menu extra (Airplay symbol) disappeared. Going into Settings -> Displays and toggling the "Show mirroring options in the menu bar when available" has no effect.

    I can however start it manually by executing this command:

    open "/System/Library/CoreServices/Menu Extras/Displays.menu"

    But as soon as I reboot, it's gone again. Doesn't stick.

    Please help :)
     
  2. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #2
    And there is an Apple TV online on your local network?
     
  3. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #3
    The meaning of the menu item has changed from a quick way to change display settings (resolutions) to just for AirPlay. If you wanted it for display settings, use Option-F1 or Option-F2 to bring up the Display Preferences quickly.
     
  4. trondah thread starter macrumors 6502

    Joined:
    Dec 1, 2008
    #4
    I don't have an AppleTV, I need it to control mirroring on/off and resolution for my TV set when connected. Any way to make the menuextra sticky?
     
  5. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #5
    As I stated, the meaning of the menu has changed and is now for AirPlay only. It doesn't matter if it is sticky or not. Use Option-F1 or Option-F2 to bring up the Display Preference pane which allows you to turn on/off mirroring and set resolutions.
     
  6. Suanmiao macrumors member

    Joined:
    May 3, 2008
    #6

    did you find a way to get it back? I'm on ML GM and mirroring option menu bar icon is still no show, so frustrating!
     
  7. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #7
    That menu bar icon is now for AirPlay only (that's why its symbol is different). If you have an AirPlay capable device, the menu bar icon will show. There is no longer a menu bar icon for controlling externally connected displays. You can use Option-F1 or Option-F2 to quickly access the System Preferences Display pane to change mirroring and resolutions.
     
  8. Suanmiao macrumors member

    Joined:
    May 3, 2008
    #8
    That sucks, I'm on projector all the time giving presentations and stuff, what a major inconvenience!
     
  9. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #9
    I am too, but I never have to adjust the controls after the first time, so it really doesn't matter.
     
  10. trondah thread starter macrumors 6502

    Joined:
    Dec 1, 2008
    #10
    Not completely correct. The icon can still be used to turn on mirroring, and also control the "match desktop size to" option.

    But the resolution selection is gone now, and that's kinda what I was looking for.
     
  11. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #11
    When I force it on with an external monitor attached I don't get any of that, just a link to the preference pane. I am surprised that it shows the old icon, though.
     

    Attached Files:

  12. stiwi macrumors regular

    Joined:
    Nov 13, 2010
    Location:
    Singapore
    #12
    Apple is getting crazy. 10.9 won't have dual monitor support at all with all those "improvements" since Lion. They just want to prepare you for it that using dual monitor setup is useless.
     
  13. epakman macrumors newbie

    Joined:
    Oct 21, 2012
    #13
    Hi,

    After I connect my mb pro running mac os 10.8.2 to apple tv 2 via airplay I lost the icon with an arrow and monitor at the top right row.

    But the most important problem is my mb pro doesn't recognizes the tv that I used to use for screen mirroring via thunderbolt port to HDMI.

    That happened just after my first use the airplay with apple tv 2. Any solution ideas for me to mirror screen with HDMI again?


    PS: Detect displays icon was showed before airplay connection. But now I can only see it if I press option button. Even it does not detects my tv though.

    BR
     
  14. ajftw macrumors newbie

    Joined:
    Feb 6, 2014
    #14
  15. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #15
    Well, it's an old thread and I discovered the Display Menu App over year ago and started using it myself. But my solution (when this thread was active) to just use Option-F1 or Option-F2 to get to the display preferences still works with Mavericks as well.
     

Share This Page