"Mismatch" problem with installing a new system :(

Discussion in 'MacBook Pro' started by itismelee, Apr 24, 2015.

  1. itismelee macrumors newbie

    Joined:
    Apr 24, 2015
    #1
    Hello people,

    I had to erase the disk on my MacBook Pro and install Yosemite from Apple site, but after installation finished I received this message:

    "OS X could not be installed on your computer.
    A mismatch between the MBR and GPT partition maps is not supported with this operation. Quit the installer to restart your computer and try again."

    When I restart I get the same result. I don't understand it.

    I read somewhere that it may have something to do with resizing partitions after installing Bootcamp. If so then the damage is already done! But how can I turn around this problem?

    Hope you can help.

    Lee

    PS: I don't have the system CD anymore.
     
  2. itismelee thread starter macrumors newbie

    Joined:
    Apr 24, 2015
  3. pl0ink macrumors newbie

    Joined:
    May 7, 2015
    #3
    Same problem


    Hi,

    I have the same problem, how did you fix it?
     
  4. pl0ink macrumors newbie

    Joined:
    May 7, 2015
    #4
    Fixed!

    I fixed it using these instructions and used the gdisk util from the clonezilla livedisk (freeware):

    Mark Ulmer
    Feb 15, 2014 1:15 PM
    Re: Win 8.1 Upgrade causes GPT/MBR Mismatch
    in response to sakman74
    Yes. First, download gdisk (URL in the OP) and run the installer package. Then run gdisk from a terminal window and run the v (verify command). If verify indicates no problems, then you're good to go and can just type "q" to quit. However, if it shows something like this, then you have the problem:

    sudo gdisk /dev/disk0
    Command (? for help): v

    Warning! Mismatched GPT and MBR partition! MBR partition 4, of type 0x07, has no corresponding GPT partition! You may continue, but this condition might cause data loss in the future!
    Identified 1 problems!

    Next, display the MBR partition table and make note of the start and end sectors for your BOOTCAMP partition. This should be partition 4 unless you've added additional partition(s), which is not officially supported by Boot Camp. It should show something like this:

    Command (? for help): r
    Recovery/transformation command (? for help): o

    Disk size is 1953525168 sectors (931.5 GiB)
    MBR disk identifier: 0x7C170CB2
    MBR partitions:

    Number Boot Start Sector End Sector Status Code
    1 1 409639 primary 0xEE
    2 409640 975693095 primary 0xAF
    3 975693096 976962631 primary 0xAB
    4 * 976963584 1952806911 primary 0x07

    Next, display the GPT partition table information. Compare the start and end sectors for partition 4 to the MBR partition 4 start and end sectors. Most likely the start sectors will match, but the end sectors will be different.

    Recovery/transformation command (? for help): m
    Command (? for help): p

    Number Start (sector) End (sector) Size Code Name
    1 40 409639 200.0 MiB EF00 EFI System Partition
    2 409640 975693095 465.1 GiB AF00 Customer
    3 975693096 976962631 619.9 MiB AB00 Recovery HD
    4 976963584 1953523711 465.7 GiB 0700 BOOTCAMP

    Next, delete the GPT partition 4. (Note: this does not delete the actual partition from disk. It only deletes gdisk's in-memory representation of the GPT).

    Command (? for help): d
    Partition number (1-4): 4

    Now, create a new partition 4 using the start and end sector values from the MBR partition 4.

    Command (? for help): n
    Partition number (4-128, default 4): 4
    First sector (34-1953525134, default = 976962632) or {+-}size{KMGTP}: 976963584
    Last sector (976963584-1953525134, default = 1953525134) or {+-}size{KMGTP}: 1952806911
    Current type is 'Apple HFS/HFS+'
    Hex code or GUID (L to show codes, Enter = AF00): 0700
    Changed type of partition to 'Microsoft basic data'

    Now, change the name of the new partition 4 to BOOTCAMP:

    Command (? for help): c
    Partition number (1-4): 4
    Enter name: BOOTCAMP

    Run the verify command. It should report no problems. If it still reports a problem, quit (q command) and start over.

    Command (? for help): v

    If everything checks out, write new partition table to disk and exit.

    Command (? for help): w

    Reboot and test your dual boot setup to verify all is working correctly.


    From this link: https://discussions.apple.com/thread/5892735
     
  5. davidcater macrumors newbie

    davidcater

    Joined:
    Aug 19, 2015
    #5
    Ffs...are you freaking kidding me? Those are instructions I would expect when installing Linux, not upgrading my Mac OS.
     
  6. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #6
    Well they are the same thing so what did you expect, they both run on the same basic system. the OP would not have had to do it if they hadn't messed up the restore partition on their drive in the first place.
     
  7. davidcater macrumors newbie

    davidcater

    Joined:
    Aug 19, 2015
    #7
    I guess my point is that I'm not sure what I did to "mess up" my restore partition. The basic flow of my experience was:
    • Buy the MacBook Pro
    • Install Bootcamp on it with Windows 8.1
    • Use it for a couple of years.
    • Upgrade to Windows 10
    • Reboot as a Mac
    • Attempt to upgrade to Yosemite
    Presumably at some point in that process I "messed up" my partitions by doing something, but I have no idea what. I certainly haven't been mucking around with editing my partitions.
     

Share This Page