Mismatching Colors in Safari and Finder

Discussion in 'Mac Apps and Mac App Store' started by dehory, Jun 25, 2009.

  1. dehory macrumors regular

    Joined:
    Sep 17, 2008
    #1
    I am having a bizarre problem where colors are not matching up in Safari and Finder.

    In Finder, the labels appear like this:

    [​IMG]

    Yet if you look closely, the red, yellow, green and orange labels do not match the colors of the little label swatches in the context menu.

    In Safari 4, map pins look like this:

    [​IMG]

    But (again in Safari 4), if I pull up the box to select different icons and pins, the colors of the corresponding pins look like this:

    [​IMG]

    As you can see, the mismatched colors look much more muted/dark than the correct colors.

    I do not have this problem in Firefox, so it is not a wholly systemwide issue.

    What could possibly be wrong, and how can I fix it? :confused:

    N.B. I have tried changing to different ColorSync profiles, but to no avail.
     
  2. dehory thread starter macrumors regular

    Joined:
    Sep 17, 2008
  3. dehory thread starter macrumors regular

    Joined:
    Sep 17, 2008
    #3
    As a follow up to my original problem, I've also noticed similar color mismatches between different programs' close/minimize/maximize buttons. To wit:

    [​IMG]

    [​IMG]

    :confused:
     
  4. dehory thread starter macrumors regular

    Joined:
    Sep 17, 2008
    #4
    And the colors in my Finder window have changed!

    [​IMG]

    It looks more similar now to the context menu color swatches. I have not changed any color settings in any program, repaired any permissions, or done anything to fiddle with colors in my system...
     
  5. freesonwang macrumors member

    Joined:
    Apr 19, 2009
    #5
    Off the top of my head (without doing weird theming stuff) that sounds like color profile problem. Did you do anything with the System Preferences->Displays?
     
  6. dehory thread starter macrumors regular

    Joined:
    Sep 17, 2008
    #6
    That's what occurred to me at first too, but no, it's nothing to do with ColorSync profiles. I've tried different ones and the colors are still off.
     

Share This Page