Misses first 2 letters when typing into a new window?

Discussion in 'MacBook Pro' started by niemo810, Nov 27, 2007.

  1. niemo810 macrumors member

    Joined:
    Apr 26, 2007
    #1
    Sometimes, NOT all the time, my MacBook misses the first two letters when typing into a window that hasn't been typed into in awhile. This has become very annoying, but I don't know if it's the same problem that other people have been describing in other threads. It's done this to me time and time again, and it only seems to be the first 2 letters I type, no matter what letters they are. It's driving me crazy!


    Has anyone else had this problem?
     
  2. afultz075 macrumors member

    Joined:
    Jun 23, 2007
    #2
    Same thing on my MBP. I guess it's a fairly common issue that's been around for awhile that Apple continually doesn't fix.
     
  3. chelsel macrumors 6502

    Joined:
    May 24, 2007
    #3
    I haven't noticed this problem on Tiger, but my fiancee has it occur daily on her new MBP with Leopard. It appears to be a Leopard issue and is a big reason I am not upgrading to Leopard just yet.
     
  4. agore macrumors member

    Joined:
    Oct 26, 2006
    #4
    This happens on my new SR MBP, but it's always only the first letter. This is probably because of the MBP's higher speed.<P>
    I find that the Keyclick utility (Sourceforge) really improves my typing accuracy. In particular, I know right away if I miss that first charactder typed into a new window.
     
  5. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #5
    Yep...has been happening for at least a year on my PowerBook. Running Tiger the whole time. Doesn't seem as bad as it used to be, but the lag is still there rather frequently.
     
  6. hogprint macrumors regular

    hogprint

    Joined:
    Oct 25, 2006
    Location:
    Wisconsin
    #6
    it only happens to me when I have my USB mouse connected.
     
  7. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #7
    I having been getting this as well since installing Leopard.

    With all these keyboard problems coming with Leopard I believe Apple has toyed around with the keyboard handler (part of OS) and the way that the OS handles multiple processes. It seems that some things that used to be incredibly responsive are not anymore and some other things which never were that responsive are now more responsive. It's just a shot in the dark but I wouldn't be surprised.
     
  8. chelsel macrumors 6502

    Joined:
    May 24, 2007
    #8
    Come to think of it, I was having this problem with Tiger initially... had to uncheck the Energy Saver preference "Put the hard disk(s) to sleep when possible".

    You might want to try that too.
     

Share This Page