Missing a video plugin in Safari

Discussion in 'Mac Apps and Mac App Store' started by messedkid, Jun 1, 2008.

  1. messedkid macrumors 6502

    messedkid

    Joined:
    Jul 8, 2007
    Location:
    Oshawa, ON
    #1
    I visit the website www.watchxonline.com frequently. I moved to Germany from Canada, and sure as hell ain't watching Family Guy, The simpsons and American Dad in German! So I love this site! :D


    But Safari..for some reason, won't play some videos. I just get a plugin symbol with a question mark (maybe its a question mark...I'm on a PC at work, can't check right now).

    I also use Flock on my mac...to easily keep in touch with friends back home via Facebook, and Flock plays the same video I would not be able to watch on Safari. I have updated to the newest Flash + shockwave and even Divx plugins..and still won't play. What am I missing?

    If you want to check..go to the site and look for the first 3 videos of Season 3 of American Dad. Those are some of the ones I remember that do not play on my safari. :(
     
  2. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #2
    I've had issues playing video before on some sites and installed Perian. It worked for me.
     
  3. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #3
    These videos are Flash-based. They should play in Safari, but don't in yours or mine. I have the most recent release version of Flash installed. I am considering trying the beta of Flash 10. Soon after installing the current version, I saw it play a video for about half-a-second and then go blank. For whatever reason, this version of Flash appears not to like Safari.
     

Share This Page