Missing app settings...

Discussion in 'Jailbreaks and iOS Hacks' started by Arkanok, Apr 2, 2009.

  1. Arkanok macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #1
    I just decided to jailbreak my phone using quickpwn to the jailbreak version 2.2.1, and everything went smoothly but there's one problem that just happened today, read on.

    So after the jailbreak, I tested everything I could and all was fine. Today, I went to the settings tab to change the setting of one of my apps (tweetie, which I did purchase prior to the jailbreak) and to my surprise, I no longer had a section to change the settings of my 3rd party apps in the settings!

    Now, I remember vividly that when I first did the jailbreak, those settings WERE there because I changed the settings for one of the apps I downloaded, it's as if the iPhone thinks that I have ZERO apps installed as if it was restored with nothing installed.

    So can anybody tell me why this happened and how to fix it? Does this mean I have to do a restore? If so, how do I restore the jailbroken version OS? Is it as simple as loading up quickpwn and doing the same thing I did before?
     
  2. equlizer macrumors regular

    Joined:
    Aug 12, 2008
    #2
    try re-installing the programs. You should not loose any settings.
     
  3. Arkanok thread starter macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #3
    I have. I've installed programs after this problem occurred and it still won't show up.
     
  4. acjrocks macrumors member

    Joined:
    Mar 24, 2008
    #4
    This happened to me yesterday. My phone was already jailbroken and it had all the app settings from the other apps showing up just fine. But yesterday I was installing some programs via Cydia and one of those programs must've messed with the list in Settings because it removed all the settings for 3rd party apps. So I went through and deleted each Cydia app I installed one by one, but the list in app Settings never came back.

    I'm not sure how it happened, but I'm thinking there was some problem installing one of the apps and it killed the list of App Settings.

    I didn't try re-installing the apps. I just backed up my phone and restored it. Everything is back now. I even installed all the same Cydia apps like before and the list of App Settings is still there. Must've been a rare happening.
     
  5. Arkanok thread starter macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #5
    Hmm
    I tried re-installing some apps that I knew had settings and they showed up one by one in the settings as I re-installed them, but shortly after, they disappeared again. I ended up doing a full backup, restore to the official non-jailbroken iPhone OS, then re-jailbroke the phone and for the first day or two, it was fine. The problem happened again a few days later, however.

    So I'm not sure why this is happening to me, to be honest, I haven't even really installed much through cydia or anything else other than a few games, and Skype (because I live in Canada and can't officially get the damn thing).

    Has anybody else experienced this sort of problem and know of a way to fix it?
     
  6. jpzsports macrumors newbie

    Joined:
    Feb 10, 2009
    #6
    I'm having this same problem. I've always had the app settings but I just checked it a few days ago to make an adjustment, and they were gone.
    I don't know how to fix it....
     

Share This Page