Missing App

Discussion in 'Mac mini' started by mikegml, Dec 13, 2013.

  1. mikegml macrumors member

    Joined:
    Sep 28, 2013
    Location:
    UK
    #1
    I have an app that I downloaded some time ago (DXO Optics) but for some reason I've never been able to keep it in the dock. It always appears as a question mark '?'.

    It launches ok when I click the question mark and it then turns into a proper icon. But it always goes back to a question mark when I quit the app. It also appears as a 'device' when launched.

    I tried to move it to 'applications' where I think it should be but it never goes in there. I cant locate it anywhere now not even in downloads which is where it used to be before my many attempts to move it to apps. Even spotlight cant find it, as it always brings up another DXO app instead.

    In fact if it weren't for the '?' icon in the dock I don't know how I'd launch it.
     
  2. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    Right-click on the icon (?) in the dock, click on options -> Show in Finder, and then tell us what you find.
     
  3. mikegml thread starter macrumors member

    Joined:
    Sep 28, 2013
    Location:
    UK
    #3
    Thanks.

    If I right click on the '?' the only option I get is 'remove from dock'.

    However, if I launch the app then I do get the 'show in finder' option, and this also brought up a dialogue box asking me to transfer the app to the applications folder which I did and it now shows up in 'my apps'.

    If this was your plan then thanks for that. I can recall doing this before, though maybe I screwed up somewhere after that.

    Hopefully this will keep the icon in the dock, thanks again.
     
  4. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #4
    Well, sort of!
    My plan was to help you locate your application, which did happen in the end. ;)
     

Share This Page