Missing Application Icons

Mac & Beanz

macrumors newbie
Original poster
May 24, 2009
25
0
I was reviewing Apple Support's Mac 101, Files and Folders Lesson and I noted that compared to some of their screenshot application items (Finder/MacIntosh HD/Applications), I have an empty space where, I assume, application folders where.

I have a blank spot (Sorted by Name) after the Address Book (which I think was the AppleScript folder), a blank sport after the DVD Player (which I think was Expose), and a couple others.

Where did my application icons go! I still have the Expose feature if I use the mouse, but I'm curious as to why they no longer appear in the folder.

Can I, without much trouble, reload all applications from my Snow Leopard upgrade disk? If so, how?

My iMac is an early 2009, 24" w/ 2.66Ghz processor.

Thank you.
 

Gregg2

macrumors 603
May 22, 2008
5,952
421
Milwaukee, WI
Can you "highlight" the blank space, and use Get Info to bring up ____ Info? (where _____ is the unknown name) Also, what is in the Preview area?

If so, the icon is probably missing in the upper left corner. You should be able to at least copy (from another Info window) and paste a generic icon there, I think. But whether or not that would also make the name below the icon appear is another question.
 

Mac & Beanz

macrumors newbie
Original poster
May 24, 2009
25
0
View -> Show View Options -> Arrange By -> Name

Better?

well, no. actually it's the same without the blank space.

I think you misunderstood... It's not that the (i.e.) Expose icon was there and not in it's proper order; it's that the icon is entirely gone.


Can you "highlight" the blank space, and use Get Info to bring up ____ Info? (where _____ is the unknown name) Also, what is in the Preview area?

If so, the icon is probably missing in the upper left corner. You should be able to at least copy (from another Info window) and paste a generic icon there, I think. But whether or not that would also make the name below the icon appear is another question.
Not working, but thanks for the try.
 

BlueRevolution

macrumors 603
Jul 26, 2004
6,054
2
Montreal, QC
well, no. actually it's the same without the blank space.

I think you misunderstood... It's not that the (i.e.) Expose icon was there and not in it's proper order; it's that the icon is entirely gone.
Just wanted to check, since that's the easiest to fix.

Exposé will still work because the icon in your Applications folder is just a script to trigger the feature, not the feature itself. It's a bit troubling to think of what else might be missing, though. You can restore missing applications from your system restore disks with Pacifist, or reboot to the disks and run an archive & install with "preserve users and network settings" selected.

What happens if you increase that in Show View Options?
I think we already covered that.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.