Missing artwork on IOS - iCloud/Match bug?

Discussion in 'iOS 9' started by gazingdown, Apr 25, 2016.

  1. gazingdown macrumors newbie

    Joined:
    Sep 10, 2015
    #1
    I have iTunes Match, or iCloud Music Library as it's now known. I do not have Apple Music sub.
    Running iMac and Macbook retina, both on latest OS. Both show all artwork for CDs that I have imported. Macbook shows the albums I imported on my iMac OK with artwork, all automatically, all good.

    However, on my iPhone 6S and brand new iPad Air 2, some albums don't show artwork. Both devices on latest iOS version.

    I have turned iCloud music on/off, hard reset, deleting albums from Mac and re-importing CD etc. but still the same issue. Some albums were imported weeks/months ago too but artwork still not showing. I don;t remember this being an issue so I think this is a recently introduced bug.

    It's the same albums missing on iPhone and iPad so I don't think there's a device local caching issue. There are some other CDs that I have imported recently that are OK. Seems to be more recently imported albums with this issue (although some that I imported years ago now have the problem)

    These albums are available in iTunes so not that obscure, here's a little list in case others do (or don't) that this issue with these albums:
    Steve Mason - Meet The Humans
    Mogwai - Atomic
    Black Mountain - IV
    Explosions in the Sky - Wilderness
    Damien Jurado - Visions of us and the land
    Jesus & Mary Chain - Darklands

    Anyone any ideas to fix (other than what I have already tried) or is this another newly introduced Apple bug?
     
  2. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #2
    A couple of tips - I posted this earlier this year:
    http://forums.macrumors.com/threads...ith-album-art-re-ac-dc.1955207/#post-22558006

    For some reason I've never figured out, my "fix" works only on a proxy of iTunes (logged in to iTM to perform the copy/paste and not while iTunes is linked to your Library). I've uploaded custom/higher res/more relevant artwork to dozens of my burned CDs and for music that's never been on the iTS. One of my selections is the same Mogwai recording you listed...

    And, leave your "other" devices on wifi with the Music app open. I have UL data on all of my iOS devices, but found that the artwork I imported wouldn't load on my iOS devices until wifi was enabled. Cheers!
     
  3. gazingdown thread starter macrumors newbie

    Joined:
    Sep 10, 2015
    #3
    Thanks.

    I remove the artwork and also remove download on my Macbook. I then manually add back in artwork and that fixes it on my iPhone/iPad (and then re-download album on Macbook of course).

    That said, it doesn't work for all albums. I then went and did the above on my iMac and that seemed to do the trick.

    The issue is knowing which (iMac or Macbook) I need to do this on!

    Ideally, Apple should really fix this bug but their software quality control/testing has gone downhill in recent years so in some ways I am not surprised....
     

Share This Page