Missing Facetime toggle iPhone 4 iOS 5.0.1

mullet

macrumors regular
Original poster
Dec 8, 2003
107
6
B'klyn
I used the pwnagetool jailbreak a few weeks back for 5.0.1 and my iPhone 4. All seemed to be fine when I noticed my iMessages weren't working. The toggle would switch on then off. No workie. Then I noticed after a little research that my Facetime settings were missing all together. No facetime toggle under Settings>Phone. Also nothing on the main settings screen. After mucking around I found that after installing SAM I could get the iMessages working. Also, after some testing I found that I could initiate and receive facetime calls so the functionality works, but I have no toggle to switch it on or off. Anyone else seeing this and know how to fix it?
 

Gav2k

macrumors G3
Jul 24, 2009
9,217
1,606
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

FaceTime isn't under phone

Settings>FaceTime
 

mullet

macrumors regular
Original poster
Dec 8, 2003
107
6
B'klyn
I don't have that either. It used to be under Settings>Phone in iOS4. So it's definitive... no Facetime settings in either place.
 

heyyitzmelissa

macrumors 6502
Jan 17, 2012
352
1
Just curious, do your push notifications work and did you activate with a legitimate SIM card or hacktivate?
 

mullet

macrumors regular
Original poster
Dec 8, 2003
107
6
B'klyn
I think push notifications are working. I get "news" updates in notification center. I haven't really checked other push notifications though. But I assume it's working. I'm on AT&T so I didn't need to hackivate. Although, to try and fix things up I reran the jailbreak using the latest Redsnow and set it not to Activate. I believe I originally did the same thing with Pwnage Tool when I initially jailbroke my phone.
 

mullet

macrumors regular
Original poster
Dec 8, 2003
107
6
B'klyn
More weirdness...

Here's an interesting update:

As I was mucking around last night with ssh and installing Stumbler Plus I ended up in some restart loop and the infamous stuck apple logo.

I then restored the phone using a new pwnage ipsw and then noticed that the Facetime settings were back. After doing all my typical customization I've noticed the Facetime settings are gone again. Weird eh? Not sure what triggered the loss of the settings, but something is going one. I have several mobile substrate plugins and have tried turning them off to see if the setting comes back. Other than that I would have to start from scratch again to see when the setting goes missing.

That's weird that no one else is seeing this.
 

Similar threads

  • Devoured
8
Replies
8
Views
1K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.