missing first letters when typing on MBP

Discussion in 'macOS' started by chihiro, Nov 27, 2007.

  1. chihiro macrumors regular

    Joined:
    Mar 25, 2007
    #1
    hi
    i bought my first MBP 4 weeks ago and i notice that problem with the missing letter(ost time the first one)
    I would like to ask you do you think this is a hardware problem or a keyboard problem please?
    sth there numlock dosnt respond and lock evrything so i have to restart the computer.
    what do you think is that problem relatet to? softwae,hardware,keyboard?
    do you think it can be fixed if i go to the store.I have apple care for 3 years.

    thank you in advanced for your help
     
  2. 119576 Guest

    119576

    Joined:
    Aug 6, 2007
    #2
    Sounds like a keyboard problem to me. If it's consistent and you can prove it at the Apple Store, they should look into it. Be prepared to leave your computer with them though
     
  3. skwij macrumors 6502

    Joined:
    Apr 10, 2006
    Location:
    Belleville, ON, Canada
    #3
    Happens with my Macbook C2D bought in Feb, too. Also with a friends, bought a month or so earlier. Drives us both nuts, especially when searching Spotlight or filling in webforms and the like.

    I find that if I slow down and press a little harder, it usually works fine. Most times I'm in a hurry though and don't always remember.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    How weird, I have a similar problem with my own MBP, which is about 4 months old. It only affects iTunes, though, and only some of the time, it doesn't register the first keypress.:confused:
     
  5. John01021988 macrumors 6502

    Joined:
    May 11, 2007
    #5
    Its not a hardware problem, it is OS problem. When I was in Tiger, I did not have such issue, I installed Leopard, problem appeared again..... But I havent notice it after I applied to FULL update from the apple site. You guys should downloading 10.5.1 from the apple site. IT worked for me.
     
  6. oYx macrumors regular

    Joined:
    Sep 2, 2007
    Location:
    London
    #6
    you mean to download the 10.5.1 update instead of using software update?

    noticed the same problem in leopard and had thought my fingers are not yet used to the keyboard on my new mac. happened to see this thread when i booted into windows, and typed a bit to see if the same problem exists, but it was alright.

    if anybody else downloaded the full update and has not noticed this missing keypress issue, do report back!
     
  7. yudilks macrumors regular

    Joined:
    Jan 30, 2006
    #7
    Happens to me as well

    I think this is the problem with power management... Mac OS X turns our keyboard off after prolonged idle period..
     
  8. cogsinister macrumors 6502a

    Joined:
    Aug 24, 2006
    Location:
    Fredericton NB Canada
    #8
    I have this problem with my MB, it is allways missing first letters....if i push the keys hard and right in the middle they work........

    The problem was there in Tiger as well, so i think its a hardware problem.....i just dont fancy going thru the "leaving my MB at the Apple dealership" saga again like with my old PB G4.....
     
  9. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #9
    My MBP bought in March '07 also has this problem. It has only come up since installing Leopard. I believe apple has toyed around with the way the OS handles multiple processes and the way it prioritizes them. I have some odd behavior in other programs as well since I have installed Leopard which all seem to hint at such a thing. Only time will tell.
     
  10. mainstreetmark macrumors 68020

    mainstreetmark

    Joined:
    May 7, 2003
    Location:
    Saint Augustine, FL
    #10
    Outstanding!

    It happens to other people too? Perhaps then Apple will fix it!

    Now, it's just a waiting game
     
  11. Evader macrumors newbie

    Joined:
    Dec 20, 2007
    #11
    it happens to everyone whether they realise it or not. the keyboard shuts off to save power. the first key press wakes the keyboard back up (turns it on) then it registers subsequent presses.

    I wish they'd fix it too. but I'm not sure they can.
     
  12. Stevp1 macrumors regular

    Joined:
    Dec 8, 2003
    #12
    me too

    I'll add myself to that list... happens on my MBP
     
  13. appie57 macrumors 6502

    appie57

    Joined:
    Oct 27, 2006
    Location:
    Netherlands
    #13
    Elp!

    There is a thread 10 miles long on Apple about this problem, generally known as the ELP! first key missing problem. There seems to be no solution; hardware problem :(
     
  14. zblaxberg Guest

    zblaxberg

    Joined:
    Jan 22, 2007
    #14
    I get this problem, it has to be software but they have yet to fix it.
     
  15. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #15
    There was already one fix for this problem on Software Update, so make sure you've run Software Update. That said, I don't think the fix fixed it.
     
  16. JD76 macrumors member

    Joined:
    Jan 23, 2008
    #16
    I have a new MBP and I had this problem as well. My laptop came with Leopard installed. I got Apple Care to mail me Tiger disks. They wanted me to erase everything and re-install Leopard but I installed Tiger instead and now the problem is gone! They felt it may have been a hardware issue or a compatibilty issue with Leopard and other programs. After Tiger, it runs fine. I kinda like Tiger more anyway... I like my iCal having its drawer back.

    Check the "ELP" discussions on the apple forum. Most Apple reps say they never heard of the problem but you can give them the bug # listed in the posts.
     
  17. DaveTheGrey macrumors 6502a

    DaveTheGrey

    Joined:
    Dec 28, 2003
    #17
    lol :mad:
     
  18. Evader macrumors newbie

    Joined:
    Dec 20, 2007
    #19
    LOL, the issue has been resolved, i think, i haven't had the issue in a while, in a couple recent keyboard firmware updates.. LOL at it being a ribbon issue that tape fixes. it has to do with the keyboard going into a power save mode.
     
  19. berdinkerdickle macrumors newbie

    Joined:
    Aug 5, 2008
    #20
    That's nice that the fw update worked for you. It didn't for many.
    For the many who have been fighting this issue since Tiger, and now running the latest version of Leopard, and have applied all the updates along with the kb fw update, and made sure the update took, and pram'd, did a complete re-install, and are being jacked around by apple, and paid $2500, should I say more?
    For me, this isn't a LOL matter. It's a 'For Crying Out Loud' matter.
    You may think it's funny that someone would be so desperate to find a solution for sentences like; elp, my eyboard often drops the irst letter on my $2500 otebook.
     

Share This Page