Missing Fonts in Snow Leopard...??

Discussion in 'Mac Basics and Help' started by mrtekkid, Aug 30, 2009.

  1. mrtekkid macrumors regular

    Sep 28, 2006
    Hey, I am hoping that someone can help me out with this current issue that I have run into after installing Snow Leopard on my machine. It is really the first complaint I have since I put the OS in on the 28th and I am just having time to sit down and toy around with it and I discovered this issue.

    When I was playing around in a few Adobe applications, specifically Flash, it warned me when opening a project that I was missing a few fonts form the project and that they would be substituted. Going into my font Library I looked for the fonts that it said were missing and confirmed that they STILL EXISTED in the folder. After double checking, I realized that a lot of my fonts were missing from the application.

    After opening Word 2008, I noticed that a lot of my fonts missing from Word as well. I shut down Word and tried rebuilding the Font Cache by dragging the Word font cache file out to the desktop but Word did not rebuild it's font menu with the missing fonts.

    Here's where it gets interesting. When opening an Apple application like Mail, all of my fonts that are present in the font folder show up. This is INCLUDING all of the fonts that are missing in Adobe and Word. Opening a program like Adium also shows that all of the fonts are there.

    Is there any reasoning behind this?? How can I go about attempting to fix this issue? How do I get Word and Adobe to identify ALL of my fonts in my font folder? I did not have this issue with Leopard.

    Suggestions are welcome.

    I am going to try to boot into 32-bit Snow Leopard and see if that fixes the issue or not in case part of the issue is with Adobe and Word running in 64-bit. If that solves the issue, I will just run in 32-bit if it gives me my fonts back.
  2. mrtekkid thread starter macrumors regular

    Sep 28, 2006
    All of my fonts are installed in Library > Fonts so that they are accessible to other users on the system. Booting into 32-bit mode did not resolve the issue. Going to create a new user account and see if I can get the fonts to be identified through a new account.

    Will update this post with my findings.

    EDIT: Creating a new user account did not solve the issue.
  3. coreytree macrumors newbie

    Aug 30, 2009
    I'm having the same prob in Motion

    The font I do not see in Motion, but do see elsewhere, is a Postscript type 1 font. I'm running SL in 32 bit.
  4. phjellming macrumors newbie

    Aug 31, 2009

    This worked for me, hopefully it will for you too. Go to Font Book, you should see that you have some fonts duplicated, hit Cmd+A to select all and then click Edit > Resolve Duplicates and then either restart or log out and log back in again. That got all of my fonts back into Photoshop, Word, etc.
  5. mrtekkid thread starter macrumors regular

    Sep 28, 2006
    Just another update.... I have semi-solved the issue. Clearing out duplicates did not help though there was a small amount of them in there....

    I made aliases of the fonts in my /Library/Fonts folder and moved them into the /Library/Application Support/Adobe/Fonts folder. This made the fonts visible in Photoshop, Illustrator and InDesign. The one application that needs it and still isn't giving it to me is Flash. I am going to try to reset Adobe's font cache and hope that it resets it again and puts the fonts in Flash and doesn't remove it from everything else. I haven't gotten them to work in Word yet either....
  6. katambe macrumors newbie

    Sep 11, 2009
    i have the same issue. Even when updated the SL with the 10.6.1. the same thing appens. I have Times New Roman instaled, but strangely in flash cs4 and word 2008 it doesn't appear in the font list. I've updated the full ADobe cs4 package, and i dont know what to do now. any ideas??? thanks!
  7. PurpleLaser macrumors newbie

    Sep 19, 2009
    Same Problem in both Flash and Same Dialogs

    I have the problem on a MacMini (with upgraded firmware, 10.6.1, and Flash 10, and removed duplicates)

    My other iMac works fine
    Any more hints?
  8. iflyer macrumors newbie

    Oct 20, 2009
    Font prob

    Anyone try to do a permissions and ACL repair from the Snow Leopard disc, thus resetting home folder permissions (which it could be using for fonts instead of system)? The permissions for Mail are updated/replaced when the OS updates but possibly not these user/non Apple apps. Also I would consider renaming the .plist file for flash with the .old in the preferences and seeing if, when SL regenerates the file the prob is solved.
  9. TeckniX macrumors newbie

    Nov 5, 2009
    Bringing this thread back up - I had everything working correctly until I upgraded to Snow Leopard - Now none of my user fonts are showing up!!

    I tried to remove/reinstall the fonts with no luck. I also tried to simply create a new font library which didn't help either.

    Any help would be greatly appreciated as all of those fonts are crucial!
  10. KlausOstberg macrumors newbie

    Oct 7, 2010
    Solution that helped me

    You will need the application "Onyx" (http://www.titanium.free.fr)
    Login as administrator.
    Start application Onyx.
    Choose "Cleaning" from toolbar.
    Choose the "Font"-tab of the cleaning panel.
    Set checkmark "Microsoft program".
    Press the button in the lower right corner to execute your cleaning.
    Restart your computer.
    If you are lucky, all your installed fonts should be available in Words 2008.
  11. Tailspin45 macrumors newbie

    Jan 9, 2012
    Yup worked for me. Apple's Pages had all fonts, but Microsoft Word and Adobe Photoshop did not. Ran Onyx font cleaning with system/user, Microsoft and Adobe checked, restarted, and there they were!
  12. Seahawksean macrumors newbie

    Jan 23, 2013
    Thank you KlausOstberg!!! (Post #10) Your suggestion fixed my problem of fonts having disappeared from Illustrator CS4 on my Mac after upgrading to Snow Leopard.

Share This Page