missing fonts

Hobbit

macrumors member
Original poster
Jun 24, 2005
87
0
Hello,


I keep getting an error message saying that there are missing fonts everytime i open keynote, pages or iweb. The fonts missing include Bodoni, Baskerville and Helveticaneue. Any idea how this problem can be fixed?

This is happening on my new macbook. I never added or deleted any fonts from the computer.


Thanks for you help.
 

CanadaRAM

macrumors G5
How did you install Keynote? From the original iWork disk?

Whatever you are opening, it calls for fonts that you don't have. By the looks of the names, those are commercial fonts from Adobe, and not any that come free with the machine or with iWork, although I may be mistaken because I don't have that sw to check.

Are you opening a template that someone else made?
 

Hobbit

macrumors member
Original poster
Jun 24, 2005
87
0
iWork is factory pre-installed..the problem is also with iWeb.

It happens even when i open a new document after choosing a template.

No other programmes such as MS office/acrobat are simultaneously open.
 

Hobbit

macrumors member
Original poster
Jun 24, 2005
87
0
Just an update..

i used spotlight to search for the missing fonts and found them in ../library/fonts. I double-clicked on them and installed them...this solved the problem with one particular pages template...then i opened another pages template and got another error messabe with even a longer list of missing fonts which are available in /library/fonts but don't seem to be installed!

Any idea how i can install all the fonts without individually clicking on all of them?
 

funkychunkz

macrumors 6502a
Jun 1, 2005
501
0
Ottawa, Canada
Weird, must have deleted a prefernce or something. Just command-O everything in that font folder. These aren't system crytical fonts, but I don't see why they would be there without being enabled (then again tiger may be different from panther, what I use).