Missing iPhoto Theme

Discussion in 'Mac Apps and Mac App Store' started by mrtekkid, Nov 15, 2009.

  1. mrtekkid macrumors regular

    Joined:
    Sep 28, 2006
    #1
    I have a Mid 2009 uMBP 15" running 10.6.2 4 GB ram and iLife '09.

    This summer I put together a slideshow for a youth group using iPhoto and the Scrapbook theme. It looked fantastic having the photos displayed at the end of the week.

    Recently I went to use the same theme for a present for a friend.

    [​IMG]

    I had used Xslimmer on iPhoto at some point (mistake...i know...) So I deleted iPhoto and installed from the Applications Installation disc and ran the iPhoto update from Software update.

    The new iPhoto installation has the theme missing too.

    I created a new user to see if it was an account issue... no luck.

    It was okay under Leopard... so I am guessing that it is probably a Snow Leopard bug??

    Any suggestions?? Is there a potential corrupted plist I have to delete? And if so, where is it? Or should I call Apple for help??
     
  2. mahoneyjoe macrumors newbie

    Joined:
    Oct 24, 2007
    #2
    I'm thinking you want to make a photo book as a gift, not the slideshow? If so, maybe the scrapbook theme isn't available as a book? I've got iPhoto 06, so I can't compare directly; the slideshow themes in 06 doesn't include a scrapbook theme.
     
  3. mrtekkid thread starter macrumors regular

    Joined:
    Sep 28, 2006
    #3
    There is actually a slideshow theme that is a scrapbook.

    http://www.youtube.com/watch?v=Bh6sP0vJDr0

    I may have to give Apple a call... this is a new computer and should exceed the requirements that reportedly would not allow some themes to be displayed on older systems.
     
  4. mrtekkid thread starter macrumors regular

    Joined:
    Sep 28, 2006
    #4
    **bump**

    Went to the Apple Store the other day and talked to them about the missing theme. It has now spread to iDVD as well with the missing Revolution theme as well as a few others.

    "Genius" told me that CoreServices was corrupted and an Archive and Install would fix the problem. Got home and did that. Messed up my computer, and did not solve the issue. Reverted back to my lat Time Machine backup and had to reset all my Little Snitch preferences.

    [​IMG]
     
  5. AGuyInFlorida macrumors newbie

    Joined:
    Feb 22, 2010
    #5
    Same issue here

    I just upgrade my MBP from iLife 08 to 09 and I am experiencing the EXACT same issue. I trashed application and preferences, reinstalled and have the same results. Is there any more news on a resolution for this problem?
     
  6. mrtekkid thread starter macrumors regular

    Joined:
    Sep 28, 2006
    #6
    If you happen to take it to an Apple Store... DO NOT... I REPEAT...DO NOT Archive and install. The "genius" told me that an archive and install would fix the issue since the "CoreServices" was corrupted. He told me that he garaunteed with "99.9% certainty" that it would solve my problem.

    After I did the reinstall and it reinstalled the OS files, it DID NOT solve the situation. I actually ended up wiping the drive and doing a Time Machine Restore in order to get my computer back to somewhat where I had it before.

    My computer came with '09 installed but I had to upgrade my '08 library to make it work. This summer the theme above worked fine, and then a few months later it as well as some iDVD themes just disappeared. A fresh install of iLife again did not solve the problem. I am wondering if I did not remove all of the files hidden in the back end. Though I have deleted a fair amount of the plist files and put them back when it did not solve the problem.

    I haven't had any new developments in this case and while I do not use iPhoto themes or iDVD themes all that often... it would be nice to have them, "JUST WORK". I would like to have them working though to do a small project here or there.

    Kinda a little disappointed that Apple Genius couldn't solve it and made the situation worse and then I had to bail myself out. May go back to the other Apple Store and try there instead and see if anyone else knows what's going on.
     
  7. AGuyInFlorida2 macrumors newbie

    Joined:
    Mar 1, 2010
    #7
    Resolved

    I contacted AppleCare and received fantastic customer support. After some pretty serious investigation by them on my laptop, it was determined that I had corrupted files in a specific folder. They advised me to remove all the files in "/Library/Graphics/Quartz Composer Plug-Ins" and restart the machine.

    iPhoto scrapbook theme and iDVD now working just fine!

    I can't say enough about how kind they were on the phone.
     
  8. mrtekkid thread starter macrumors regular

    Joined:
    Sep 28, 2006
    #8
    I'm glad you resolved the issue. We have different problems causing the same issue. I removed the same contents of that folder and got no where off a reboot.

    Also noticed this issue in iTunes:
    [​IMG]

    [​IMG]

    I am guessing that this is probably related at this point. Something else to note when I call them. Hopefully I get someone who knows what they are talking about when I call.

    If someone who can't see my screen fixes my issue better than someone whom actually saw it... I'll swear by their phone support... I've had more success with them in the past anyhow.
     
  9. AGuyInFlorida2 macrumors newbie

    Joined:
    Mar 1, 2010
    #9
    Have you tried removing Perian?

    I've read some things about Perian and Snow Leopard not getting along. It might be worth a try since it's simple to remove and put it back. I'm using Perian 1.2 and things are working fine, so it's lust a long shot. Sorry I can't be of more help.
     
  10. mrtekkid thread starter macrumors regular

    Joined:
    Sep 28, 2006
    #10
    I didn't have any success there either. I was running Perian 1.1 and uninstalled it and rebooted. When that didn't work I cleared that folder out you told me two again, with no success. I then installed Perian 1.2 and rebooted and that didn't solve it either. Once that didn't work, I put those files back in again.

    I'm debating if DIVX is causing the issue since that still asks to boot 32 bit mode System Prefences when I am in 64 bit mode. Maybe I should reboot in 32 bit and see what happens without that stuff installed including Perian and that folder emptied.

    Will report back.
     
  11. mrtekkid thread starter macrumors regular

    Joined:
    Sep 28, 2006
    #11
    Still no luck. Running in 32-bit mode does not resolve the issue either.

    Anyone else know why this is doing this?

    To recap:
    Missing Scrapbook iPhoto theme. (shows up as black)
    Missing some iDVD themes (show up as black)
    iTunes visualizers show up as above.

    Archive and Install did NOTHING.
    Running between 64 and 32-bit didn't fix it either.
    Updating Perian didn't resolve the issue either.
     

Share This Page