Missing Keystrokes on SR MB After 10.5.2

Discussion in 'MacBook Pro' started by jlan, Feb 15, 2008.

  1. jlan macrumors newbie

    Joined:
    Jan 3, 2008
    #1
    Hi,

    I am having problems with missing keystrokes after updating to 10.5.2 (from 10.5.1). And yes, I downloaded the supposed "fix" back in December, but that really didn't do anything. The problem was happening in 10.5.1, but only happened when I left the MB idle for a while. Now, the problem is happening much more frequently.. even after I just finish typing a sentence. And it's not just the first keystroke, it skips up to 3 keystrokes.

    I know I press down firmly with each keystroke, but the problem still persists. If anyone has the same problem or knows of any solutions, please comment.

    Thanks in advance :)
     
  2. jlan thread starter macrumors newbie

    Joined:
    Jan 3, 2008
  3. anotherarunan macrumors 6502

    Joined:
    Sep 18, 2007
    Location:
    London, United Kingdom (UK)
    #3
    mine seems to be fine...is this the same problem that happend before with the SR Macbooks when they were released?
     
  4. bking1000 macrumors 6502a

    Joined:
    Dec 29, 2007
    #4
    Right after I updated my SRMB to 10.5.2, the letter "j" starting working over intermittently. It's since seemed to have healed itself. Very odd.
     
  5. coltks2004 macrumors newbie

    Joined:
    Feb 3, 2008
    #5
    I just bought my girlfriend a 2.0 ghz macbook a week ago, and she has been complaining of her skipping letters, it happens mostly with the u, n, e, o and space. I'm glad to hear that she isn't the only one. I took it to an apple repair center, and they tried to tell me it was because she only had 1 gig of ram. Some joke that is.
     
  6. twm macrumors newbie

    Joined:
    Mar 16, 2008
    #6
    I'm having the same problem in 10.5.2, except that it hasn't healed itself yet, unfortunately. I just got a new MacBook last week and the 'p' key sometimes doesn't work if I haven't been typing in awhile and if I don't hit it hard and exactly in the center. If I tap it even slightly off center, I sometimes need to tap it 2 or 3 times before it registers. It's weird because I can keep tapping it in the same way and the later keystrokes will eventually register, which makes me think that something in the software is missing the earlier keystrokes.

    I haven't figured out how to reproduce it 100% of the time yet, but I can reproduce it sometimes if I move the pointer with the trackpad, wait a few seconds, and then tap the 'p' key some way other than hard and directly in the center. Maybe if we can come up with a good way to reproduce it all the time, it will be enough to register on Apple's radar.

    I took it into the Genius Bar at the Apple store and the genius told me to do a system archive and restore in order to rule out software errors. I haven't had a chance to do that yet. I don't know why that would be an issue since I just bought it, but perhaps I will give it a try this week.

    If anybody else has any luck in reproducing it reliably or getting Apple to take it seriously, please post the details.

    Thanks,
    - Tim Macinta
     
  7. TraustiB macrumors member

    Joined:
    Nov 27, 2007
    Location:
    Reykjavík, Iceland
    #7
    A friends MacBook had the issue of the keyboard going entirely unresponsive for minutes at a time. The only solution that worked was when I removed the top case and unplugged and replugged the keyboard cable, it's been quiet since then (early January).

    And I've also been having the problematic issue of the first and somtimes second letter of a new sentence not typing, but the rest do. Usually happends after a bit of time idle. Can almost reproduce the issue every time when the computer has been idle and I press the command + space to get the Spotlight. Once I start to type, the first 2 letters don't appear.

    Very strange indeed.
     
  8. bking1000 macrumors 6502a

    Joined:
    Dec 29, 2007
    #8
    My issue with the J has resurfaced. It's annoying, but not worth doing a system back up and restore or getting into the physical case. I'm just learning to live with it. Striking it hard and dead center seems to help.

    My workplace DELL, in terms of hardware, has noooo problems. But, in terms of software... well, it runs windows. :p

    I'm not trying to justify Apple or let them off the hook, but the OS/HW is a kit, and overall, this "j" issue is my ONLY issue with MB/OSX combo, and so is a minor annoyance compared to Dell/Win headaches (like Friday. Windows background updated while I was on the phone with a customer, working through an issue, and windows kept asking me to "reboot now or reboot later." I had to tell it to "reboot later" about 4 times while on a series of calls. ugh!)
     
  9. twm macrumors newbie

    Joined:
    Mar 16, 2008
    #9
    So I tried the Archive and Install last night with no luck. It still skips the first 'p' (and sometimes 'a', though mainly just 'p'). I feel like the genius at the Genius Bar just told me to try an Archive and Install in the hope that it would seem like too arduous a task to be worth it to cure a minor annoyance. The annoyance factor is growing for me, though. The keyboard is something that should just work, and this is really slowing down my typing. I will probably take it back to the Apple Store and try again, especially now that I've figured out how to reproduce it semi-regularly and now that I've jumped through the Archive and Install hoop.

    - Tim Macinta
     
  10. almightychey macrumors newbie

    Joined:
    Apr 15, 2007
    #10
    jlan - I have the same problem. Seems to have gotten worse since the last update that was suppose to fix this. It is very frustrating and disappointing. I don't know how to fix it, but I hope they fix it soon.
     
  11. crayonshin macrumors member

    Joined:
    Mar 10, 2008
    Location:
    Japan
    #11
    yeah, i still have the problem with initial key presses not registering. sometimes, it doesn't even need to be idle for long. for example, i will type in an url in firefox. then, i'll read the page for a bit and type in another url and the first letter won't show up in the address window.

    so basically, the last update that was supposed to fix this did not work. however, i do think that it made things better since i don't experience this quite as much as i used to.
     
  12. twm macrumors newbie

    Joined:
    Mar 16, 2008
    #12
    I took my MacBook back to the Genius Bar for a second try and things went much better this time. The genius first popped the 'p' key off and then pulled out a small piece of rubber debris which appeared to be the problem. He popped the key back on and voila - it no longer missed those keystrokes. I asked if he could take a look at the 'a' key too since it also failed to register every once in awhile, though not really to the point of being a serious annoyance like the 'p' key. He popped off the 'a' key as well but didn't see any physical problem, so he took my MacBook to the back and replaced the keyboard entirely. It is working wonderfully now.

    I probably would have been happy had he just fixed the 'p' key (the new keyboard is a nice bonus), so for everybody else experiencing the problem, it might be physical rather than a software problem. The genius figured out where to look for the debris by pressing the key from various angles in order to see where it was less receptive. Maybe this will help for those who have a similar problem (I don't know how safe removing your own keys would be, though).

    - Tim Macinta
     
  13. bking1000 macrumors 6502a

    Joined:
    Dec 29, 2007
    #13
    Thanks for the encouraging hope! Maybe this can be fixed after all.
     
  14. Czechaston macrumors newbie

    Joined:
    Mar 26, 2008
    #14
    Got better and then got worse

    I was also experienced the missing initial keystroke, applied the fix, and then it seemed to be better. However, suddenly it is worse again, from about a week ago. No particular letters, just the first keystroke, in any application. I spent hours on the phone with AppleCare, and they tried hard but had no idea. I dread doing it all again, but somehow we have to get Apple to take this seriously. We just have to go on making a fuss until they fix it properly.

    I will make the call tomorrow, and post an update here.
     

Share This Page