Missing photos from iPhoto sync in iTunes to iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Birsay, May 28, 2011.

  1. Birsay macrumors newbie

    Joined:
    May 28, 2011
    #1
    I've been searching for hints as to how to fix a photo sync problem for my iPhone 4, but to no avail. If anyone has heard of something like this happening, please help!

    I use iPhoto'11 (9.1.3) to organize pictures that I want to sync with my iPhone. The problem is that when I go into iTunes (10.2.2) to select which photos to sync with my iPhone, some of the Events have missing photos. One Event, for example, has 40 photos in it, as evidenced in iPhoto, but iTunes shows the Event having zero photos. In another Event, which has 55 photos, iTunes sees 2. In other Events, iTunes sees all of the photos. Everything iTunes sees is synced fine with the iPhone. There appears to be plenty of space left on the iPhone (2.5 gigs).

    One factor might be a recent upgrade to iPhoto'11 several weeks ago. Events made and synced before the date of the upgrade appear to all be fine. After the upgrade, iTunes sees some Events as empty of photos, some Events with only a couple photos out of many, and one Event with all of the photos. Also affected are new Faces that were added after the upgrade. Although some of those people are in photos that were synced, their names are missing from the Faces list in iTunes and on the iPhone. I'm not sure if this problem started at exactly the same time of the upgrade or later, though.

    Does anyone have any insight into this? Any help would be greatly appreciated!
     
  2. fufun macrumors newbie

    Joined:
    May 30, 2011
    #2
    u r not alone...

    i've registered just to confirm that I'm having absolutely the same troubles (with my iPad) while having no clue how to fix it except for downgrading everything at all. the worst thing is that everything downgrades - iPad doesn't..

    have no idea what to do - need to show my clients the albums i've sorted/collected in iPhoto but they just won't show up in iTunes to sync them.

    since 433 seized my iPad syncing gone nuts

    …and it ain't windowz we are talking about now...

    maybe it's Sun with plasma stuff messing everything up, or Apple's finally gotten greedy and want's us all to buy new iCrap :mad:
     
  3. Birsay, May 31, 2011
    Last edited: May 31, 2011

    Birsay thread starter macrumors newbie

    Joined:
    May 28, 2011
    #3
    I seem to have found a solution:

    For each item that iTunes doesn't see (Event, Face, etc.), open iPhoto and go to that item, open it, and look at it.

    For example, if iTunes sees and Event, but says there are zero pictures in it, but iPhoto says there are 55, open iPhoto, navigate to the Event, open it, click on the first picture, space bar to enlarge, click on the display info icon at bottom right, and then view each and every picture in the Event. (It may help to edit at least one bit of information, like adding a Face, but I don't think I did that for each Event.)

    Then, go back to iTunes (plug in the iPhone), navigate to the iPhone and then Photos, verify that everything's there, and sync.

    That's what I did and the problem seems to be solved. iTunes now sees all of the pictures in the Events and syncs them to the iPhone with no problem. Weird.
     
  4. Birsay thread starter macrumors newbie

    Joined:
    May 28, 2011
    #4
    Unfortunately the fix I describe has to be redone each time I close and reopen the programs and sync the iPhone. Does anyone have a permanent fix?
     
  5. cutykamu macrumors newbie

    Joined:
    Jan 15, 2010
    #5
    buddy, i have exact same problem which you described above, i'm trying to find the solution too but still with no luck, pls let me know if you have found something which can help me ( and others) with the same problem.
     
  6. ToxicMan macrumors member

    Joined:
    Jun 22, 2010
    #6
    Having the exact same issue too. Cannot find a solution...
     
  7. mluisbrown macrumors newbie

    Joined:
    Dec 22, 2011
    Location:
    Lisbon, Portugal
    #7
    I was having the same problem, many events were showing as having 0 photos in iTunes, but were fine in iPhoto. Or so I thought.

    In my case, iPhoto appeared to be showing the event just fine with all its photos. However, when I tried to edit one of the photos in the event I discovered that iPhoto couldn't access the image file, because it wasn't there anymore! The event appears fine because it's just thumbnails.

    The cause of my problem was having recently migrated my iPhoto library to an external HD to save space on my MacBook Air's SSD. I thought I'd done this all correctly, but apparently not. Many of my earlier (pre iPhoto) events had their image files stored in a folder just under ~/Pictures/, not in the iPhoto library. iPhoto just had an alias pointing to the original.

    Thinking that everything was safely in iPhoto Library, I deleted these 'original' folders. Fortunately, I have backups of them. But it's a nasty problem because it only show up if you try to edit the photos, which could be a long time after you may have deleted the original, at which point you may no longer have a backup.
     
  8. mluisbrown macrumors newbie

    Joined:
    Dec 22, 2011
    Location:
    Lisbon, Portugal
    #8
    Still no solution. Even though I copied the missing photos back to their original location, so that the iPhoto aliases now point to the correct files, it doesn't solve the iTunes sync problem.

    iPhoto now sees the photos fine and lets me edit them and everything else, but iTunes still does not recognize them for syncing. Also, I've discovered that if you edit a referenced photo, it then becomes sync-able in iTunes, presumable because modified images are stored in the iPhoto Library folder.

    So, basically, iTunes won't recognize iPhoto photos who's original file is outside of the iPhoto Library (referenced via alias), unless you have subsequently edited the photo within iPhoto.
     
  9. dlin macrumors newbie

    Joined:
    Apr 28, 2012
    #9
    iTunes and iPhoto not syncing properly

    I had similar problems with the additional symptom of whenever iPhoto launched or I attached an iOS device, a window would pop up saying "The iPhoto library needs to be upgraded to work with this version of iPhoto". I would hit upgrade and iPhoto seemed to work fine, but the problem was that the window would still come up after relaunching iPhoto or attaching any iOS device (iPod Touch, iPad or iPhone).
    This may have started after I upgraded to Lion and migrated all my User Accounts from my external backup disk running Snow Leopard.
    I finally contacted AppleCare today, who connected me to their special iPhoto team.

    So this is on an iMac running Lion 10.7.3, with iPhoto '11 (v.9.2.3)
    They recommended a few things to do,(three different customer service people, since the methods took awhile and I had to call back) though I think the latter recommendation may have had the greater effect for the fix. However, I will provide all the recommendations.

    First of all, makes sure you have a BACKUP (Time Machine, SuperDuper, Carbon Copy Cloner, etc)

    #1: Rebuild the iPhoto Library
    - Close iPhoto if it is active
    - Hold down the Command+Option keys and Launch iPhoto
    - A window will pop up "Rebuild Photo Library"
    - Check all the boxes except "Rebuild the iPhoto Library Database from automatic backup"
    - Click Rebuild



    Resetting/Repairing ACLs
    #2: In your User Account (that is giving you the iPhoto/iTunes problem, make sure your have administrator privileges.)
    Open Terminal
    Type: sudo chmod -R -a "everyone deny delete" ~
    This may take a while
    let that run until you get a prompt

    #3: (By Christine):
    -Shut down the Mac.
    -Power on the Mac and Hold Down Command+R keys until you see the Apple logo and the spinning gear wheel and let go.
    -When you finally get to an active screen, navigate to the Utilities menu
    -Choose Terminal
    - At the prompt, type resetpassword
    - Hit return
    - A window "ResetPassword" will pop up
    - Select the appropriate Volume/hard drive at the top (e.g..Macintosh HD), esp. if you have other external hard drives attached to that Mac.
    - Select the correct Account User that is giving you the iPhoto/iTunes problem
    - DO NOT type anything in the password fields.
    - Click 'Reset' at the bottom where it says "Reset Home Folder Permissions and ACLs)
    - Once Done, navigate to the Apple Menu and Restart
    - Once your Mac has restarted and you User Account is active, Hold down the Command+Option Keys and Launch iPhoto
    - Click the Last Checkbox "Examine and repair iPhoto Library file permissions" and click Rebuild

    - When iPhoto launches, launch iTunes and attach an iOS device (Hopefully your problem is fixed)

    Good Luck!
     

    Attached Files:

Share This Page