Missing Photos in Aperture Library

Discussion in 'Digital Photography' started by crl21, Dec 18, 2007.

  1. crl21 macrumors newbie

    Joined:
    Aug 10, 2007
    #1
    I'm having trouble viewing all of my aperture library in iPhoto and in system preferences. The aperture library shows up and all of my projects show up, but not all of the pictures within the projects.

    For example, in my project "Snow Day" in Aperture there are 113 photos, but when I try to view the pictures to import the photos into iPhoto or use the photos as wallpaper it says there are only 53. There does not seem to be any rhyme or reason to why some show up and others do not. Any help would be greatly appreciated. I'm quite frustrated.
     
  2. AndrewMorrell macrumors newbie

    AndrewMorrell

    Joined:
    Dec 16, 2007
    Location:
    Shaker Heights, OH, USA
    #2
    Do you have any photos in stacks? Sometimes, if your stacks are closed, only the master will show up, and not any of the stacked versions. Give that a try.

     
  3. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #3
    The only images that will show up outside Aperture are those with previews. Did you stop preview generation at some point? Or turn off auto-generation of previews?

    You can regenerate all previews for a project by right clicking on it and choosing "Update previews for project". If it does not have existing previews this might be called something like "Generate previews for project"
     
  4. crl21 thread starter macrumors newbie

    Joined:
    Aug 10, 2007
    #4
    I think I've finally found out which pictures aren't showing up. It seems it's all of the pictures that I've made edits too. Do I need to regenerate the previews after I've made an edit to the version? How do I do this?
     
  5. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #5
    If you have automatic previews turned on then no. Otherwise try right-clicking on the version in the browser...
     
  6. Sherburn macrumors newbie

    Joined:
    May 16, 2008
    #6
    Projects and Photos Missing from Aperture

    Hello Everybody
    I've used Aperture with a Studio Book 1T external hard drive over a year. In October 2009 however I traded in my Mac Book Pro for a new 13" superdooper model with a new copy of Aperture 2.1.4. Since then something v weird and upsetting keeps happening - photos are missing from their projects and some projects are just empty. (7 in all, all diff sizes) You can see them but not open them in 'Show all projects' but not in the main screen.

    I think I know when it happens - I duplicate a photo and edit it then I transfer it on screen ('drag and drop') to a relevant project. Then I reopen Aperture and something is missing.

    There seems to be many other people suffering from same or similar experiences and no response from Aperture. I rang Apple and they'd never heard of it neither had their Aperture 'genius'.

    From other forums :- I tried 'Show all projects, thank you.
    - I've tried regenerating library without any success.
    - I tried duplicating the photos twice and importing them into iphoto and then re-importing them into aperture. (This worked the first time but just now I looked in the new version of one of the projects and there was only one photo left to view - it had five stars if that helps;)

    Please help as this is very frustrating.
    Regards
    Sherburn
     
  7. Sherburn macrumors newbie

    Joined:
    May 16, 2008

Share This Page