Resolved Mission Control Desktop Options Missing in Safari 6.0

Lostanddamned

macrumors 6502a
Original poster
May 3, 2009
647
141
London, UK
I have decided to test out using Safari as my main browser as opposed to Google Chrome. In order to do this I needed to assign it to a single desktop.

However, when I tried to do this, I found that the mission control desktop selection options were absent, as shown in the attached screenshot.

As "Safari is essential to Mac OS X" it cannot be deleted, preventing me from replacing it to see if this is related.

Has anyone encountered this before? I previously had it set to "all desktops" and on others Macs the options are present.
 

Attachments

Last edited:

nyolc8

macrumors regular
Jul 20, 2012
205
1
Do you created a second desktop before you go into that menu? Because I don't have the desktop options in that menu when I got only one desktop.
 

Lostanddamned

macrumors 6502a
Original poster
May 3, 2009
647
141
London, UK
You're missing the row of desktop icons above the safari window which shouldn't be possible. I've seen this before in Lion but I could never replicate it.
I'm not in Mission control, I've just 2 finger/right/cmd+ clicked on the icon, I presume you are referring to the ones shown in the attached image?

No clue what this means.
Since OSX 10.5, Leopard, I have been making use of the expose/mission control feature to have multiple desktops, its an essential part of my workspace environment
 

Attachments

Krazy Bill

macrumors 68030
Dec 21, 2011
2,985
3
I'm not in Mission control, I've just 2 finger/right/cmd+ clicked on the icon, I presume you are referring to the ones shown in the attached image?
Ok. I'm with you now.

As mentioned, the option to set a desktop preference for a window requires another desktop. Create one, move the window "up there" then, right click the dock icon for those options to appear.

Since OSX 10.5, Leopard, I have been making use of the expose/mission control feature to have multiple desktops, its an essential part of my workspace environment
Dude, where have you been?

The removal of "Spaces" in this version of OSX (and the former) has been a bone of contention here for a long time.
 

Lostanddamned

macrumors 6502a
Original poster
May 3, 2009
647
141
London, UK
Ok. I'm with you now.

As mentioned, the option to set a desktop preference for a window requires another desktop. Create one, move the window "up there" then, right click the dock icon for those options to appear.

Dude, where have you been?

The removal of "Spaces" in this version of OSX (and the former) has been a bone of contention here for a long time.
I have six spaces/desktops/sets of windows already. I have provided pictorial evidence of this, which you have just seen. I'm sorry if my tone is hostile, but I'm trying to fix a problem and you not only seem to have no idea as to the solution, you don't really seem to understand the terminology I am using to describe it.
 

Krazy Bill

macrumors 68030
Dec 21, 2011
2,985
3
I have six spaces/desktops/sets of windows already. I have provided pictorial evidence of this, which you have just seen. I'm sorry if my tone is hostile, but I'm trying to fix a problem and you not only seem to have no idea as to the solution, you don't really seem to understand the terminology I am using to describe it.
Well, when you keep mixing up OS versions, it's hard to know what the hell you're asking.

There is NO MISSION CONTROL in Leopard.
 

MacManiac76

macrumors 68000
Apr 21, 2007
1,558
355
White Mntns, Arizona
I have six spaces/desktops/sets of windows already. I have provided pictorial evidence of this, which you have just seen. I'm sorry if my tone is hostile, but I'm trying to fix a problem and you not only seem to have no idea as to the solution, you don't really seem to understand the terminology I am using to describe it.
Have you tried repairing permissions? You could also try deleting the com.apple.spaces.plist file from ~/Library/Preferences and rebooting and see if that fixes it. Not sure if that's the correct file for the app/desktop assignments in ML still but that's where it is on Lion.
 

Lostanddamned

macrumors 6502a
Original poster
May 3, 2009
647
141
London, UK
Have you tried repairing permissions? You could also try deleting the com.apple.spaces.plist file from ~/Library/Preferences and rebooting and see if that fixes it. Not sure if that's the correct file for the app/desktop assignments in ML still but that's where it is on Lion.
This sounds like it might be a fix. Thanks for the advice.

Well, when you keep mixing up OS versions, it's hard to know what the hell you're asking.

There is NO MISSION CONTROL in Leopard.
since   [sins]
adverb
1. from then till now (often preceded by ever ): He was elected in 1978 and has been president ever since.
2. between a particular past time and the present; subsequently: She at first refused, but has since consented.
3. ago; before now: long since.


I'm clearly not using Leopard am I, not the fact that I'm in safari 6.0 and mission control, as well as the Notification Centre icon in the menu bar. Possibly some basic reading comprehension would help you help yourself.
 

Icy1007

macrumors 65816
Feb 26, 2011
1,041
63
Cleveland, OH
Dude, where have you been?

The removal of "Spaces" in this version of OSX (and the former) has been a bone of contention here for a long time.
What is it about his statements that are confusing you?

He has six desktops. He's had six desktops since Leopard.

Just like I've always had four desktops since SL.




...anyway...

Have you tried killing the dock?

[Terminal] -> killall Dock

That might fix your issue.
 
Last edited by a moderator: