mission control, jumping to wrong file

Discussion in 'Mac OS X Lion (10.7)' started by G0meZ, Nov 2, 2012.

  1. G0meZ, Nov 2, 2012
    Last edited: Nov 26, 2012

    G0meZ macrumors regular

    Aug 9, 2011
    ok, say i've got three pdfs open in acrobat and three documents in libreoffice... one software on one mission control space (virtual screen), the other on the next.
    when using cmd-tab to switch back and forth between the different programs, every couple of times, the system fails to give me back the last active (viewed/edited) file but shows another one open, quite arbitrarily so...:mad:

    this used to work like a charm in SLeo's spaces... now it's a mess... anyway to fix this, a workaround, or is there a good and slim spaces-equivalent for lion? or is this fixed in mtnlion?
  2. G0meZ thread starter macrumors regular

    Aug 9, 2011
  3. Norrin, Dec 19, 2012
    Last edited: Dec 19, 2012

    Norrin macrumors newbie

    Apr 15, 2011
    same here

    Yup. Same problem. Driving me crazy. My scenario is slightly different.
    I have terminal on desktop 1.
    one safari window on desktop 2
    another safari window on desktop 3
    and xcode on desktop 4.

    from safari on desktop 2, i cmd+tab to terminal on desktop 1. i then cmd+tab back to safari. it goes to desktop 3 instead of 2.

    same thing from xcode on desktop 4. it'll go to the safari that ISN'T the most recent one.

    even worse, this is intermittent. i can cmd+tab back and forward ten times and it'll keep going back to a DIFFERENT safari window each time. can't see any different pattern whatsoever.

    fixes? people with the same problem?
  4. Norrin macrumors newbie

    Apr 15, 2011
    this must be related to mission control

    I just noticed that when cmd+tab goes to a window that was not the most recent one, it is switching to the desktop of that window that isn't the most recent one, but the window that has focus is the most recent window.

    from the previous example, desktop 2 has the most recent safari window, you're in terminal on desktop 1, and you cmd+tab but it goes to desktop 3 instead of desktop 2. But the window on desktop 2 has focus. You cmd+t to get a new tab, and the tab opens on desktop 2 not desktop 3.

    This seems to always be the case when mission control switches to a desktop that has a window for that app that isn't the most recently used window. The most recently used window still has focus....

    I swear Mission Control tried its very best to destroy everything good about OS X.
  5. G0meZ thread starter macrumors regular

    Aug 9, 2011
    agreed. ******* lion :mad::mad::mad:
    never tried mtn lion...any idea if they by now fixed those f***ups?
  6. G0meZ thread starter macrumors regular

    Aug 9, 2011
    update: upgraded to mtnlion and problems seems to be gone...

Share This Page