Mission Control Lag in Lion, iMac

Discussion in 'iMac' started by kwissylawrencek, Mar 1, 2012.

  1. kwissylawrencek macrumors member

    Nov 7, 2007
    I have been using Lion since it came out and never had any problems with it. Then one day mission control just started lagging. Rather than smoothly scaling the windows into mission control like it used to, now mission control opens and the windows snap into place, and back upon closing mission control. There is a video below for reference.
    I looked at the video and it's not just a laggy video, thats how it actually looks. Also youtube cut off the beginning of the video for some reason, but you get the ideo.


    Any ideas?
  2. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    First restart then try the Reset OS X cache system trick. Close any running programs the launch /Applications/Utilities/Terminal and run the code:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user
    Then don't close Terminal until you get another Terminal prompt. Then the reset is completed. See if this helps.
  3. alksion macrumors 68000


    Sep 10, 2010
    Los Angeles County
    I have had the same problem.. Not very Apple like if you ask me.. I don't know though, I have been quite annoyed by it.
  4. kwissylawrencek thread starter macrumors member

    Nov 7, 2007
    Unfortunately that didn't work.

    Any other ideas?
  5. sylvantemplar macrumors newbie

    Nov 14, 2011
    Are you by chance running a system that was in-place upgraded from Snow Leopard? If so, I've noticed similar on my 27" i7 iMac. My 21.5" i5 iMac (2011) is smooth as butter, though. However, it's running a fresh install of Lion - no in-place upgrade.

    Were I in your position, I would back up your media to an external hard drive and do a format -> fresh install of Lion. Don't do a Time Machine migration of your existing install, or you'll defeat the purpose. I have a sneaking suspicion that issues of this nature relate to the convenient, (but flawed) Snow Leopard -> Lion upgrade through the App Store.
  6. EEXOOO macrumors regular

    Aug 1, 2009
    I believe it doesn't happen to your 21.5" iMac because the screen resolution is only 1080p while the 27" is 1440p (which is around 4x more pixels). When my MBP 15" 6490m is connected to a 1440p display, MI tends to "lag" after some hours of usage but when I unplug the 1440p display, MI reverts to a silky smooth state.
  7. jjepyy macrumors newbie

    Apr 28, 2012
    Same problem since yesterday.

    Sadly, this started happening to me yesterday. It was all fine a few days ago.

    I did sometimes (since I bought it) noticed a little lag *a little*... minimal, but I could notice it because it wasn't as smooth as when I had no running applications.

    And now...Mission control is slow and laggy... any fixes?

    I'm using a 2011 13" MBP i5 and 8GB RAM with OS X Lion.
  8. ayala421 macrumors regular


    Sep 21, 2010
    So did anyone figure out a definite fix for this? This just happened out of the blue to me.

    I'm running 10.7.4
  9. jmpage2 macrumors 68040


    Sep 14, 2007
    I am experiencing something similar and also searching for some kind of resolution.

    I have a 27" i7 iMac with the Radeon 4850 card, 8GB of RAM and a Corsair SSD. This thing is a rocket, and yet I get occasional lagging of gestures for mission control.

    For example, sometimes I will do the four finger swipe on my magic track pad, and for several seconds the screen is just frozen and then I will get mission control or app windows to come up.

    It's rather annoying, even more so because of how fast the computer is otherwise.
  10. ayala421 macrumors regular


    Sep 21, 2010
    Download and run Xbench, but unselect "Thread Test" in their dialog box. For some reason Xbench hangs on Lion so the fix for it is to unselect thread test.

    This worked for me.
  11. jmpage2 macrumors 68040


    Sep 14, 2007
    Running Xbench fixed your problem, or unselecting thread test changed a setting in Lion that fixed the problem?
  12. ayala421 macrumors regular


    Sep 21, 2010
  13. jmpage2 macrumors 68040


    Sep 14, 2007
    I ran Xbench but I'm curious about how it could fix anything, it's just a benchmark program.
  14. Payton macrumors regular


    Nov 23, 2006
    Portland, OR
    I can second this. Been having this issue with my MacBook Pro (Santa Rosa) since Lion came out. I even wiped my drive and installed from scratch to try and fix the issue...

    After months of being annoyed, xbench has fixed it. I just ran it once with the thread test unchecked.

    Back to normal.

    THANK YOU ayala421!
  15. ayala421 macrumors regular


    Sep 21, 2010
    Honestly I have no clue, but my assumption is that xbench forces your video card to clear the lag out.


    Your welcome
  16. jmpage2 macrumors 68040


    Sep 14, 2007
    Okay, fair enough. Reboots in the past though haven't cleared it. I mean, it will not happen 100% of the time, it will just spontaneously sort of freeze up and might not do it for another day or a week then it will happen again. I will do the gesture on the trackpad for expose/mission-control/spaces and it will simply stop responding then after maybe 5-10 seconds it will respond again and whatever gesture I had been doing will suddenly "activate".
  17. HersheyTrojans macrumors newbie

    Jul 17, 2012
    (First time using the forums here, so sorry if formatting is wrong or something like that).

    To the Mission Control Lag, I have experienced this myself. I have the late 2011 Sandy Bridge 15 inch Macbook Pro with the 2.4 ghz i7. All was working great until one time when I turned it on and everything was lagged as Ive read about here. I tried a bunch of things listed on here, xbench, graphics stress test, resetting smc, all that other stuff. I took it to the apple store and after dealing with a few different people I realized there was nothing they were gonna do except tell me its a "core OS problem".

    After a complete reset of lion it worked fine, haven't had a problem in several months. But for those interested, a reset of lion will work.
  18. jmpage2 macrumors 68040


    Sep 14, 2007
    By 'resetting' Lion I am assuming you mean that you did a from-scratch installation? Did you restore from a TM Backup afterwards?
  19. Joshi83 macrumors newbie

    Mar 30, 2011
    I'm getting this almost every time on a current gen mac mini.
    I even just upgraded it from 4 to 8GB ram but still does it.
    Any hot corner action (show desktop/show all windows/show widgets) is a 3 to 4 second delay.
  20. sticko macrumors member

    Apr 26, 2010
    I have Macbook Pro retina 2.6GHz Core i7 with 16GB RAM. It basically top of the line model, but mission control is very laggy. It can even takes 3-4 secs before opening. Unbelievable!!
  21. thomas223 macrumors member

    Nov 29, 2011
    I also had Mission control problems and tried numerous fixes and nothing worked. I finally decided to erase the OS partition and reinstall the Lion via internet recovery. This fixed mission control and strangely the iMac now runs much much faster than it did the day I bought it.
  22. liveinkolor macrumors newbie

    Apr 16, 2012
    I have this problem too but it's only when I'm running more than 2 programs. Maybe it's because my ram is only 4GB. Who knows.
  23. jmpage2 macrumors 68040


    Sep 14, 2007
    With Mountain Lion this problem has only occurred a couple of times. It is definitely related to the number of window items I have open, so I suspect that it is related to the amount of memory available in either the machine or the graphics card. I do have 16GB of RAM and I do have a higher end Radeon in my 27" i7 iMac.
  24. Volkward macrumors newbie

    Sep 11, 2012
    Don't know if this helps anyone, but since I finally found a way to fix those Mission Control lags for my iMac and I'm happy again i just wanted you guys to know what I did:
    It was the application frame mode of photoshop (or maybe all the applications within the Creative Suite...) that caused the laggy Mission Control animations at my iMac.
    I tried all the other hints with dock animation, xbench, cleaning of cache, re-installing the OS and so on before - nothing worked. But as soon as I deactivated the application frame in Photoshop CS6 (Windows - Application Frame) everything went back to normal.
    Hopefully this information is at least helpful for some of you guys ;)

  25. Wreckie macrumors regular

    May 9, 2011
    I had headache with this mission control lag until I found this thread! Amazingly xBench fixed it for me, thank you alot, saved me time not having to reinstall OS.

Share This Page