Mission Control Layout lost after reboot

Discussion in 'macOS Sierra (10.12)' started by neoly19833, Feb 24, 2017.

  1. neoly19833, Feb 24, 2017
    Last edited: Feb 24, 2017

    neoly19833 macrumors newbie

    neoly19833

    Joined:
    Jul 17, 2015
    #1
    Hi everyone, I have a problem as the following:

    Every time I reboot the Mac, the Mission Control loses its layout: only 1 desktop remaining and all the windows of applications are on that desktop.

    It's MacBook Pro 2016 15" and OS X 10.12.3. I used the Time Machine to recover my personal files when I got the new MacBook Pro. I tried to open another brand new admin account without any personal files, and there is no such problem for that account. It proves that it's not hardware problem. I think some personal files somehow affects the system.

    Any help or suggestions would be appreciated!
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Sounds like there could be some corruption in your User Account and/or you've got some software running that's not entirely compatible with Sierra. These are definitely two things that can occur with migrated systems/accounts.
     
  3. neoly19833 thread starter macrumors newbie

    neoly19833

    Joined:
    Jul 17, 2015
    #3
    Thanks for the reply!~

    I tried to turn off all the auto start apps in Login items, but it didn't solve the problem.
    I know that the process controlling Mission Control is "Dock". But I didn't figure out which files in
    "~/Library" is related to the problem.

    Any suggestions for diagnosis?Thx~
     

Share This Page