Mission Control Not Loading

Discussion in 'OS X Yosemite (10.10)' started by thomasd3, Nov 5, 2014.

  1. thomasd3 macrumors newbie

    Joined:
    Nov 5, 2014
    #1
    Since upgrading to Yosemite, I can't load mission control:
    - The fingers up move on the track pad doesn't do anything.
    - The hot corners do not work.
    - When I select an app in the dock, it doesn't go to the right space anymore.
    - I can't add / remove spaces, the icons for it do not appear.

    When I try to load mission control nothing happens, it quits instantly: no error, no console output, etc.

    I have attached a trace of the app, in case it can help find what is wrong: http://pastebin.com/0FRFf3Q8

    I have no idea where to look!
     
  2. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Try to press "CMD + ALT +ESC", no need to force quite or relaunch anything, but sometimes it can bring back the mission control.
     
  3. thomasd3 thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #3
    I meant that Mission Control is not even loaded; the executable is basically not working at all, it can't be launched; there is no task running under that name.
     
  4. thomasd3 thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #4
    btw, i tried to run the mission control executable from another MBP and it's exactly the same.
    so the problem is not the executable itself.
     
  5. thomasd3 thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #5
    So, I did a re-install of Yosemite (I didn't wipe the disk because I don't want to reinstall everything) and I get the exact same thing. Mission control doesn't load, the full screen hot corner and gestures do not work either and selecting in the dock an app that is open in another space will not switch to it.
     
  6. n-evo macrumors 65816

    n-evo

    Joined:
    Aug 9, 2013
    Location:
    Amsterdam
    #6
    Mission Control / Exposé is handled by Dock.app. The Mission Control app is nothing more a trigger so you have something to put in the Dock.
     
  7. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #7
    I've seen behavior similar to this where Mission Control stops working. I have to restart my laptop in order to get it working again. A simple killall Dock doesn't do anything.

    OP, what happens when you create another profile? Does it show the same behavior?
     
  8. thomasd3 thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #8
    Another profile does the same; I also rebooted in safe mode and it's identical.

    When I ran it in xcode, I noticed that it quits after loading the GSS framework, which handles security; so it may be a permission problem somewhere (I already fixed disk permissions btw)

    About the dock, does that mean that mission control loads and then passes control to the dock app that handles the other functionalities?

    could someone do a trace (like dtruss -n "Mission Control", in the /Applications folder) so I can see where it continues after loading the GSS framework?
     
  9. thomasd3 thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #9
    Can anyone run a trace of "Mission Control" for me? I want to see what it does as mine is not working at all.

    The steps are as follow:
    1) kill mission control so it's not running
    sudo killall "Mission Control"

    2) open a shell and type:
    sudo dtruss -afs -n "Mission Control" > ~/Desktop/trussoutput.txt

    3) load mission control
    by clicking on the icon..

    The output of the shell will go to a file called 'trussoutput.txt' on your desktop; if you could send me that file, or put the contents on pastebin.com, it would help be greatly in trying to figure out what is happening. Mine seems to be stopping abruptly after loading the GSS library...

    thanks!
     

Share This Page