Misson Control Show Desktop mouse shortcut won't work

Discussion in 'Mac OS X Lion (10.7)' started by Diogones, May 10, 2012.

  1. Diogones macrumors regular


    Dec 23, 2009
    Hey all,

    I have a 2006 Core 2 Duo iMac running the latest version of Lion (10.7.4, as of this writing) and it runs well. There is just one little annoying problem I have run into lately that I haven't solved, despite finding other posts online with the exact same problem.

    In my System Preferences, under the Mission Control options, the Show Desktop shortcut selector works with any keyboard shortcut I assign to it. However, when I try to assign any mouse button as a shortcut, it does not work at all.

    The strange thing is, it used to work awhile back, so I'm wondering if some sort of .plist got corrupted or somehow wrongly edited. I did reboot into Safe Mode, and ran a Permissions Repair from there, and I also reset the PMC by unplugging the Mac for a minute. I also ran Preferential Treatment with full permissions for both User and System Preferences, but all the .plist files it checked came up clean.

    Unfortunately, none of the above worked, hence why I am posting this: if anyone has any suggestions or advice on how to get the mouse shortcut working for Show Desktop again, I'd love to hear it!
  2. Diogones thread starter macrumors regular


    Dec 23, 2009
    Well I deleted the preference file:


    and after rebooting I got the shortcut working briefly. However after working with the Mac for a while it stopped again. I'm on the right track here, since it worked at first. Is there some program I could use to edit the pesky file, since it doesn't seem to be working right?
  3. Deraillor macrumors newbie

    Jul 23, 2012
    Same problem

    Very similar setup, same exact problem. I'll try deleting the plist and see if that helps, thanks for the lead.
  4. AppleFan1179 macrumors member

    Apr 28, 2015
    Happy to report this is still broken in Mac OS Mojave.

Share This Page