Mixed Mac/PC Home Network Problem

Discussion in 'macOS' started by Howard54, Jan 2, 2010.

  1. Howard54 macrumors member

    Joined:
    Oct 16, 2009
    #1
    I just got my first Mac and I am trying to integrate it into my home network with a number of Windows PCs. I have turned on sharing on the Mac and on all of the PCs.

    The Mac finds the router and connects to the internet with no problem. The PCs all find the Mac and can access the shared folders.

    However, the Mac does not find any of the PCs, and no shared resources show up in the Finder Sidebar.

    Any suggestions would be appreciated. Thanks.
     
  2. illy123 macrumors member

    Joined:
    Jan 1, 2010
    #2
    I have a similar issue.

    Try opening connect to server in the menu for Finder and enter the samba protocol followed by the network name of the computer (e.g. smb://desktopwindows).

    Also make sure that in network preferences -> network -> advanced -> somewhere you have the domain set to match the windows workgroup (although I think you already have else windows wouldn't have recognized it).
     
  3. Howard54 thread starter macrumors member

    Joined:
    Oct 16, 2009
    #3
    OK, I solved the problem and it had an interesting twist to it. In the Finder I went to Go-Connect to Server and entered "smb://name of the windows server", which got me to the credentials box. But when I typed in the user name and password it didn't work. I got a message saying that I had an invalid password. But when I tried the same solution from the Mac to access my Windows laptop on the network it did work.

    Turns out that an account password is not enough, you must also be required to use that password at startup on the PC. My desktop is used by the family and has only one account which did not require a password on startup. My laptop did. Once I changed the setting on the desktop, the solution worked on the desktop too.

    Now each time I start my Mac I have to mount the shared drive. Is that normal under Mac/UNIX, or is there a way to have the shared drive show up automatically as they do under Windows?
     

Share This Page