mkdir permission denied

Discussion in 'macOS' started by benyaya, Apr 14, 2010.

  1. benyaya macrumors newbie

    Joined:
    Apr 14, 2010
    #1
    I tried to install a xfig under /bin/portslocation/

    bash-3.2$ cd bin/
    bash-3.2$ mkdir portslocation
    mkdir: portslocation: Permission denied
    bash-3.2$ ls -l |grep bin
    drwxr-xr-x@ 39 root wheel 1326 Mar 13 10:23 bin
    bash-3.2$ chmod 777 bin
    chmod: Unable to change file mode on bin: Operation not permitted

    also I failed to switch to su account
    bash-3.2$ su
    Password:
    su: Sorry
    but there is only one administration account on my computer, I donno what is wrong with it. I have just switched from PC to Mac, don't know the system very well. please help. thanks.
     
  2. dashcs macrumors regular

    Joined:
    Oct 2, 2009
    #2
    permissions

    Heres the thing,you don't have permission inside the Bin Folder by default.

    If you Get Info on the Bin folder,it would say system - read/write,everyone - read only.

    You have 2 options.
    You can change the permissions on the bin folder to give you read and write access by clicking on get info on the Bin folder then scroll down to sharing & permissions.

    Or log into the root account which has full access to do everything and get the job done then log back into your account
    http://docs.info.apple.com/article.html?path=Mac/10.6/en/11778.html

    Personally I recommend to just log in root and get the job done if you don't know what your doing.

    One of the things you need to watch out is permissions on the apple computer.
    If do alot of things like options 1 for all permissions issues and change all the default system permissions,your going to have problems.
    One of the most common mistake ppl do,is change the entire permissions on the mac hd to read/write on the whole HD with enclosed items selected.
    You pretty much to re-install at that point since you computer won't restart.


    Edit-Damn kinda jump the gun here.
    Thought you were doing this inside finder and not in terminal.
    Side not,if you want to force something done in terminal use the 'sudo' command before your action.
    http://developer.apple.com/mac/library/documentation/Darwin/Reference/ManPages/man8/sudo.8.html

    Again you may want to research a bit
     
  3. benyaya thread starter macrumors newbie

    Joined:
    Apr 14, 2010

Share This Page