MKV Player for OS X

Discussion in 'Mac Apps and Mac App Store' started by caen1, Jun 10, 2012.

  1. caen1 macrumors member

    Jul 22, 2011
    I have many 720p MKV video files and a mid-2009 13" MBP. The problem is that when I try to play one of them with VLC or MPlayerX, it starts lagging after about 10 mins and the CPU processes are way high in Activity Monitor. Not all of them, but many.

    I figure it's either because of the file or the app, but the latter seems more likely. So what can I do? Thanks!
  2. locust76 macrumors 6502a

    Jan 23, 2009
    Install Windows and see if you have the same problem. If yes, then you've probably got a hardware issue. If not, it's a software issue, probably related to drivers.
  3. AdrianK macrumors 68020

    Feb 19, 2011
    Odd, I have the same machine (2.26GHz) and with VLC it crunches through though most raw blurays without any problems. MplayerX doesn't seem to perform quite so well, but it still manages 720p no problems at all.

    Is it just the VLC/MPX process which starts consuming a lot of processor time or others as well?
  4. caen1 thread starter macrumors member

    Jul 22, 2011
    Only the player app and kernel_task, if you set the filter to "All Processes". In fact, it's something like kernel_task 80% and VLC 35%.
  5. northernmunky, Jun 10, 2012
    Last edited: Jun 10, 2012

    northernmunky macrumors 6502a


    Jan 19, 2007
    London, Taipei
    I had the same Macbook Pro too (I've upgraded since) but I know a few tricks to get them to play better.

    1. Use fastest connection to your storage i.e. FW800
    2. Boot into a fresh user account, without any software being loaded in the background (this is very effective)
    3. Make sure you are running on your Nvidia chip
    4. Have the mote up to date point updates to your os (i.e. 10.6.8 or 10.7.4 [currently]) so you have the most up to date graphics chip drivers. This should allow your playback software to offload the processing of the H.264 to your graphics card.
    5. I personally had better performance on MplayerX sometimes over VLC - but either way use the latest version running in 64bit.

    Combine all of these and you'll get no lag.
  6. Mr. Retrofire macrumors 603

    Mr. Retrofire

    Mar 2, 2010
    Increase the file cache value:

    See also:

    MediaInfo can show you the bitrate of the video stream within the mkv-file:
    (higher bitrates require higher file cache values)

    Some people use also the wrong H.264 encoding settings, which causes problems in many software and hardware decoders.
  7. caen1 thread starter macrumors member

    Jul 22, 2011
    I play them from my internal SSD.
    Tried it, same result.
    The 13" MBP has only got one integrated video card, the GeForce 9400M
    I keep everything up to date.
    I actually tried VLC only because MPlayerX started lagging.

    The cache didn't help. Shouldn't the right H.264 encoding settings be auto-detected? If not, how can I tweak them?

Share This Page