MKV Video Playback Issues on 10.6

Discussion in 'Mac Apps and Mac App Store' started by Makosuke, Sep 13, 2009.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    I'm using a 2009 mini as my home theater PC, and thus far it had run pretty much flawlessly. However, I tried playing some fansubs for the first time with Snow Leopard today, and I couldn't seem to get anything working properly. Wondering if anybody else is having similar problems or has any suggestions. This is on 10.6.1, 4GB RAM, 1920x1080 video output, and nothing else running; videos were medium-definition h264 MKVs with soft subtitles. SL is running everything it can in 64bit, but I haven't done anything crazy like try to boot the 64bit kernel (or, really, anything at all past a stock install).

    First tried VLC. It simply stalled at the barber-pole progress bar where it would usually be pre-scanning the video or whatever it does when you first open one. Tried a few different videos, including ones I know played fine before, same behavior on all of them. VLC 1.0.1.

    Next I tried QT Player 7 with the latest 1.1.4 Perian installed. It opened the video fine, but playing fullscreen was dropping frames all over the place, to the point it was basically unwatchable.

    So then in desperation I went to Plex; this, finally, played the video properly. But it also was suffering from rather severe tearing, which I don't remember being an issue with it in the past (in fact, after either 10.4 or 10.5--forget which it was that added coalesced frames to the entire OS--I haven't seen tearing anywhere).

    Did 10.6 goof up something in the video subsystem that Perian and Plex rely on to cause this, or is there just something weird with my system? Anybody else having any of these problems?
     
  2. Corrode macrumors 6502a

    Corrode

    Joined:
    Dec 26, 2008
    Location:
    Calgary, AB
    #2
    I'd say VLC is your best bet. You just gotta be patient when opening those mkv's. Takes up to a minute sometimes. The issue is to do with loading subtitles. There's a fix online, something to do with terminal, but I don't eff with terminal so I decided to live with the wait. The developers are aware of the problem and are working on a fix, if you're willing to wait for that.
     
  3. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Ahh, thanks for the tip on VLC. I wasn't Googling for the right phrase, but knowing it was subtitles causing it and it was just a delay, not broken, lead me to a useful post on the VLC forums. Looks like a known problem that's going to be fixed, and based on the "fix it with this" tip it's due in some way to VLC not having write permissions to the X11 font cache of all things.

    Regardless, the temporary workaround, is the following terminal command:
    Code:
    sudo chmod a+w /usr/X11/var/cache/fontconfig
    Not sure if this'll have any security implications, but seems highly unlikely, and I can't see it breaking anything.

    Doesn't explain QT's horrible lag nor why Plex was tearing (though Plex apparently has other SL issues, so maybe it's just in the same bag), but at least I can get VLC working again.
     

Share This Page