MKVtools Help - Error Code "No Such File or Directory"

Discussion in 'Apple TV and Home Theater' started by meaghani, Jan 1, 2011.

  1. meaghani macrumors newbie

    Joined:
    Jan 1, 2011
    #1
    Okay, so I have a .mkv file of a movie that is in French and has three different subtitle options. They are all included within the file itself.

    I went to convert the video to .mp4 and selected the video track, audio track and English subtitles and chose to burn them into the video but every time I try to convert it, it says the conversion was successful but it only takes a second and where there should be the completed .mp4, there is an .log file that says:

    "Error: (mkvextract) The file '/Users/meaghani/Movies/Amelie [Ame' could not be opened for reading (No such file or directory)."

    Which is weird because the video loads just fine into the application and I'm able to watch the video with VLC Player, so I don't see how it could be corrupted.

    Please, please, please help?
     
  2. Bye Bye Baby macrumors 65816

    Bye Bye Baby

    Joined:
    Sep 15, 2004
    Location:
    i(am in the)cloud
    #2
    What program are you using for your encoding?
     
  3. kuwisdelu, Jan 2, 2011
    Last edited: Jan 2, 2011

    kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #3
    What settings are you using?

    When that happens to me with MKVTools, it's usually because I'm trying to pass-thru something that won't work in an mp4. E.g., trying to pass-thru ogg audio, or trying to pass-thru the video when you have the subtitles set to burn-in, neither of which will work.

    If neither of those sound like the problem, you can get a recent nightly of Handbrake that'll burn-in the subtitles like you like (if they're in an mkv, I'm assuming they're .ass/.ssa? — if so, the release version won't work, but the recent nightly builds will handle that fine).

    I find MKVTools is most useful for remuxing into an mp4 when I have a weird audio codec and/or I want to extract soft subs. If you're going to hard-sub, Handbrake has worked well for me.
     
  4. meaghani thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #4
    I don't know if the problem is my settings. I tried just extracting the subtitles and it came up with the same error message...

    My subtitles are actually in .srt format. Would the newest nightly build handle that? And I'm sorry, I'm really new at this, so I don't know what a nightly is.

    I would love to use just Handbrake for this but I was under the impression that you have to add an external SRT file if there are multiple subtitles within the file.
     
  5. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #5
    I'm not sure why it's giving the same problem just for extracting it... that's strange.

    That would be your problem. You can't burn-in srt subtitles; you can only use them as soft subtitles.

    If you have an mkv with H.264 video, AAC audio, and srt subtitles, then you're easiest bet is using Subler. Get Subler, make a new file, and then just drag-and-drop the mkv onto the new file. Remux into an mp4.
     
  6. meaghani thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #6
    Thank you so much for all your help! That did the trick! Much easier to use for a newb like me. <3
     

Share This Page