MKVTools not burning subtitles

Discussion in 'Apple TV and Home Theater' started by jason2811, Mar 21, 2011.

  1. jason2811 macrumors 6502a

    May 8, 2006
    I currently have a movie in Spanish with English subtitles in MKV format. I ran the file through MKVtools and put it on the AppleTV2 preset and set subtitles to "burn." However, in the final MP4 file, the subtitles are not burned in when I play the new file in VLC or Quicktime. They don't show up at all. I've tried to convert it twice with MKVTools and no luck. Can someone tell me how to fix this or the proper settings to use in MKVtools to actually burn the subtitles into the movie? Thanks!
  2. ayzee macrumors 6502a


    Jun 12, 2008
    I have the same problem, I can't get the subtitles to be burned in. When I first started using mkvtools I burnt in subtitles by mistake on the first movie I did. You could try trashing and installing the app again. And trashing the preference file
  3. jason2811 thread starter macrumors 6502a

    May 8, 2006
    Basically all I want to do is burn the subtitles into the movie and change the movie from MKV to MP4 format with the burnt in subtitles.
  4. peterjcat macrumors 6502

    Jun 14, 2010
    You could always try Handbrake instead? MKVTools is great when you don't need to re-encode the video stream, you just want to change the container and the audio. Burning in subtitles requires a complete re-encode of the video stream, and Handbrake is unsurpassed for that. If you don't want to re-encode the video stream, your only option is to use soft subtitles.
  5. nixsun macrumors newbie

    Apr 4, 2011
    Did you find a solution to this?

    I have tried many many things and only one worked but degraded my video quality tremendously.

Share This Page