ML 1630 printer + Time Capsule = Argh

Discussion in 'Mac Accessories' started by akm3, Feb 2, 2009.

  1. akm3 macrumors 68020

    Joined:
    Nov 15, 2007
    #1
    I have a Time Capsule hooked up to a Samsung ML-1630 with USB.

    When I go to the Airport config, it sees and configures the printer just fine. Macs on my network can see that bounjour is sharing a printer, and add it just fine.

    The printer will only print ONE page before the time capsule 'loses' the printer. By 'loses' I mean one page comes out, you go to Airport, go to Manual Setup, go to the Printers tab and - it says there are no printers connected. The only way to get it back is to unplug the time capsule, plug it back in, and voila! It sees the printer again - allowing you to go into the Mac print queue and take your stuff off hold, which will allow you to print ONE more page.

    This is very, very frustrating, does anyone have a solution?
     
  2. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
    #2
    OK At the Apple discussions this printer is apparently 'one that will not work wirelessly through an Airport Express or Time Capsule...since the 10.5.2 update. No reason why it worked and now doesn't, and Samsung blames Apple, Apple blames Samsung.

    A workaround was to set it up as an IP printer...anyone know how to do that?
     
  3. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
    #3
    Well, my issue appears to be at least temporarily resolved. I gave the Time Capsule a static IP address (192.168.100.199) and Changed the name of the printer from Samsung ML-1630 to Samsung ML-1630 TC.

    Both these things shouldn't make a difference, but I haven't had the issue re-occur since.

    Strange.
    -Allen
     
  4. J147 macrumors newbie

    Joined:
    Feb 3, 2009
    #4
    I have the exact same set up and the same problem. How do you set it up with the IP address?
     
  5. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
    #5
    In the AirPort utility, I selected the time capsule, set manual configuation, and changed it to a static IP address on the Internet tab, (you also have to enter subnet mask and domain addressses...95% chance the subnet mask is 255.255.255.0 and the domain address the same as your router address...)

    Then, on the printers tab I deleted the Samsung, and readded it, and changed the name. I don't think it matters what the name is changed TO, just that it isn't the default name. I couldn't tell you why, it makes no sense to me - maybe that part is voodoo.

    Then, delete the printer from any macs that had it added, and readd it. When it says 'location' delete Time Capsule and put in the static IP address you chose.

    Since doing this, I haven't had any problems.
     
  6. Lime-Lite macrumors newbie

    Joined:
    May 22, 2009
    #6
    Solution..?

    Hey

    Ok, after about a year now i finally found the solution to this. I think the whole problem is that the airport extreme/express is struggling with the port to the printer.

    This is what worked for me after months of trying.
    First get your Airport IP address:

    [​IMG]

    Then go to System Preferences. And add your printer using the HP Jetdirect Socket. And put in your airport IP-address. THEN.. add the port number as well. And it should be :9101.

    [​IMG]

    Then choose the printer driver as well.

    Hope this helps. If anyone could try this out and see if the printer prints more than one page?

    If it helps please leave a response.

    Thanks
     
  7. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
    #7
    My solution above worked...for awhile. Then it got flaky again requiring printer restarts.

    I finally gave up on it and am using a Mac Mini as my server for everything, including print server for the printer. Since then, it works great.

    I don't want to break my setup to test your method, but hopefully someone else will.
     

Share This Page