ML Internet Recovery not working (upgraded from SL)

biasx31

macrumors newbie
Original poster
Oct 14, 2008
22
0
Hi everyone,

iam having problems using the internet recovery function. My Macbook is a Mid-2010. It shipped with Snow Leopard so i could upgrade to Mountain Lion via the App Store. This worked perfect.

Afterwards i've Installed the EFI Firmware Update to activate internet recovery.

oday I've bough a new Hard Drive and thought i should be able to install a clean copy of ML via internet recovery right ?

Holding Command+R to Enter Recovery mode (takes a few minutes downloads the recovery image i guess)

During the Installation it asks for my Apple ID and thats it. It just goes back to the harddrive selection window and aks me for my Apple ID Again if press continue.

Any Idea whats wrong here ? I could of course use the old hd to create a bootable cd/stick whatever from ML but i'd really like to see internet recovery working.
 

MTShipp

macrumors 6502a
Mar 25, 2009
693
81
Raleigh, North Carolina
The same thing happened to me this past weekend. The only difference is that it downloaded Lion. I ended up having to restore from TM then build a USB and install ML from that.
 

nangariel

macrumors member
Oct 18, 2011
44
0
The Internet recovery is actually accessed by pressing option+cmd+R while booting, cmd+R starts recovery from the recovery partition on the hard drive.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,662
9,288
California
What you are seeing is the firmware based (EFI) Internet Recovery at this point can only install Lion. You can read more about it here.

----------

The Internet recovery is actually accessed by pressing option+cmd+R while booting, cmd+R starts recovery from the recovery partition on the hard drive.
Not if there is no Recovery HD partition on the drive, like with a new, blank drive. command-r boot will first look for a Recovery HD partition and if none it present it will go straight to Internet Recovery on its own.
 

biasx31

macrumors newbie
Original poster
Oct 14, 2008
22
0
What you are seeing is the firmware based (EFI) Internet Recovery at this point can only install Lion. You can read more about it here.

----------



Not if there is no Recovery HD partition on the drive, like with a new, blank drive. command-r boot will first look for a Recovery HD partition and if none it present it will go straight to Internet Recovery on its own.
Thanks for Info but then Apple seriously screwed something. It clearly states OSX 10.8 Mountain Lion before asking me for my Apple ID!

edit:

I think this is because i went from SL straight to ML. I think at some point (after entering my apple Id for the n'th time it said something like "you do not own lion" don't remember the exact words.

Is there a way to still purchase Lion ?
 
Last edited:

dcorban

macrumors 6502a
Oct 29, 2007
913
28
I assume you entered an Apple ID that has purchased Mountain Lion?

Did you try using command-option-r? Maybe its a bug if you only use command-r.
 

biasx31

macrumors newbie
Original poster
Oct 14, 2008
22
0
Doesn't matter if I use Command+Option+R or Command+R.

Yes of course I used the Apple ID I purchased ML with ;) But anyway if not i'd at least expect a message that I am not authorized to install Mountain Lion
 

echo.park

macrumors regular
Aug 4, 2011
101
0
I think it's the servers. There are problems with logging in with Apple ID in the App Store. Even when you log off, there are problems. Thats what several people report in German Mac forums. I used a USB instead.