ML Mail Upgrade Stuck

Discussion in 'Mac Apps and Mac App Store' started by charliex5, Jul 25, 2012.

  1. charliex5 macrumors regular

    Joined:
    Jun 27, 2008
    Location:
    Seattle, WA
    #1
    I upgraded from Lion to Mountain Lion this morning and am loving it but when I opened Mail it said it needed to upgrade the database. Its been going for about four hours now and seems to be stuck. Any suggestions on what to do?

    Thank you!
     
  2. asteriscoamarel macrumors newbie

    Joined:
    Jul 25, 2012
    #2
    the same for me ..

    I'm in teh same situation.
    Could you solve it? Please HELP!!
     
  3. charliex5 thread starter macrumors regular

    Joined:
    Jun 27, 2008
    Location:
    Seattle, WA
    #3
    I just ran this in Terminal:

    rm -f ~/Library/Mail/V2/MailData/Envelope\ Index

    It will supposedly rebuild the database rather than upgrade it. Its currently importing all my emails. I'll post the result once I'm done.
     
  4. asteriscoamarel macrumors newbie

    Joined:
    Jul 25, 2012
  5. charliex5 thread starter macrumors regular

    Joined:
    Jun 27, 2008
    Location:
    Seattle, WA
    #5
    Well, it got stuck again. There must be some certain emails that are corrupted or something. I really have no idea. I ended up deleting and adding my accounts again. Not really a solution but it worked.
     
  6. asteriscoamarel macrumors newbie

    Joined:
    Jul 25, 2012
    #6
    How did you deleted you mail accounts? I cant even open mail. :/
     
  7. asteriscoamarel macrumors newbie

    Joined:
    Jul 25, 2012
  8. rtrueman macrumors member

    rtrueman

    Joined:
    Jan 5, 2009
    #8
    Deleting and re-adding email account is a pain, but manageable. Are you able to retain all the emails stored locally? This is my biggest fear when I upgrade. Losing years of email history would be a major issue for me.

    Recently, under Lion, I had a Mail issue where all of my email accounts disappeared. The messages were still in the Library and re-adding the accounts using the same names "linked" the emails. No problems after a rebuild of the mail Spotlight index. Hopefully, this works for ML as well.

    Rob
     
  9. trainman macrumors newbie

    Joined:
    Jun 13, 2012
    Location:
    Kissimmee Florida
    #9
    stuck mail restored

    Had same problem SBBOD for an hour. Restored normal operation by clicking the mail in the dock and lo and behold it gave the option to force quit which I did. After mail closed I reopened it and it is working perfectly.
     
  10. asteriscoamarel macrumors newbie

    Joined:
    Jul 25, 2012
    #10
    I had to delete my emails and let the imap restore the again.
    :/
     
  11. Jackboot79 macrumors newbie

    Joined:
    Jul 25, 2012
    Location:
    Sacramento, CA
    #11
    I found a fix...for me

    I force quit the application several times after letting it "upgrade" for quite some time. This didn't do anything, as it would restart in the stuck spot as before. I restarted my MBP and after it rebooted, the Mail "upgrade" took about 5 seconds.

    Hope this helps!!
     
  12. WesCole macrumors 6502a

    Joined:
    Jul 1, 2010
    Location:
    Texas
    #12
    This is the ticket right here!
     
  13. MaxRool macrumors member

    Joined:
    Dec 19, 2001
    Location:
    Lives in Melbourne, works in Sydney
    #13
    After several Force Quits of Mail and several Restarts (including Safe Mode) with no success I tried charliex5's solution except I moved the file to my home dir rather than delete it.
    mv ~/Library/Mail/V2/MailData/Envelope\ Index ~/
    Anyway this did the trick for me after a couple Mail restarts to rebuild the index etc.

    HTH and thanks to the others for tips.
     

Share This Page