ML: Office crashing on every launch

Discussion in 'OS X Mountain Lion (10.8)' started by gabriel_uk, Aug 3, 2012.

  1. gabriel_uk macrumors regular

    Apr 19, 2005
    After installing ML on my rMBP, all Office 2008 programs crashed on launch.

    So I just installed Office 2011 - again, MS Office REFUSES to open.

    Went to the MS "Support" page - but any link to actual help (eg a phone number) delivers "PAGE NOT FOUND".

    Fiddling with CS6 to make it work on my rMBP was bad enough (it still crashes, mind you - esp Dw) - but Office is totally defunct.

    Any advice gratefully received.
  2. RRmalvado macrumors 6502

    May 27, 2010
    Go to your "Library->Saved Application State" folder and delete any reference to the Office programs.

    Then check for Office updates by going to your "HDD->Library->Application Support->Microsoft->MAU2.0" and run the Microsoft AutoUpdate tool.

    And then attempt to run them again.
  3. gabriel_uk thread starter macrumors regular

    Apr 19, 2005
    Thanks RRmalvado - much appreciated...

    Office 2011 was already fully updated (ver 14.2.3).

    Deleted the only MS Microsoft file in Library->Saved Application State.

    However, Word, Excel and PP all continue to crash on opening.
  4. idiiamots macrumors member

    Feb 15, 2010
    Seattle, WA
    Check if you have "Vivaldi" font. If so, remove it. There are other threads that talk about that font causing issues for Office.
  5. gabriel_uk thread starter macrumors regular

    Apr 19, 2005
    Thanks idiiamots - yes, that fixed it!!

    Very much appreciate your assistance ...RRmalvado's too.
  6. ivanoats macrumors newbie


    Nov 12, 2006
    Seattle, WA
    still crashing after trying above ideas

    Tried all of the steps above, all MS Office Apps are crashing on start, even the updater. Anyone else have ideas?
  7. borderheeler macrumors newbie

    Aug 13, 2012
    In the same boat

    Just a useless "Me too" post here - any help is appreciated.

    I have no Vivaldi font (I was amazed by this, actually, since I have over 1000 fonts, and was really hoping this was my problem), and for the life of me I can't find a Saved Application State folder anywhere, even searching invisible files. Otherwise, Office 2011 is updated, and all its apps still crash upon launch, now that I have Mountain Lion.

    Thanks for any advice!

    - BH
  8. borderheeler macrumors newbie

    Aug 13, 2012

    ivanoats, I did end up fixing my launch problem and now have Word and Excel back, fully functional. Here is how I did it, thanks to this thread at the Microsoft forums:

    First, did some usual maintenance including repairing permissions. This didn't help me, but one should do it.

    Then I cleaned out all "bad" fonts, and this was the thing that worked for me. See this article:

    Be sure to click on EVERY font family name in Font Book so that the little arrow beside the font family name points down and you can see every font within the family. I missed doing this the first time, and you often will not see the duplicates if you do not do this. It is extremely tedious, but you need to do it. As you do this, follow the instructions in the Font Weeding article.

    In addition to cleaning out - sending to the trash - every single duplicate font, I also selected all my fonts in Font Book (under User), then validated them, then Removed all fonts that had a serious validation failure. If you have fonts that have a minor validation failure that you don't care about, also remove those.

    So now you have removed all duplicate fonts and all validation-serious-failed fonts. Now restart your computer. It might take a while since it is rebuilding your font cache. Well, it took a while for me, as I have hundreds of fonts (and got rid of hundreds of bad ones).

    At this point, you should be good to go. It looks like Office 2011 just won't work under Mountain Lion if there are duplicate or corrupted fonts, even if those fonts are disabled. Those fonts need to be moved to the trash.

    Let us know if this works for you.
  9. goc3 macrumors newbie

    Aug 5, 2010
    I was having the same problem with any Office 2011 application crashing on launching after updating to 10.8.3. I tried all the suggestions on this thread (repair permissions, font weeding) and I completely removed all Office-related files and did a fresh install, to no avail. See this article for completely removing Office 2011:

    As a last-ditch effort, after completely uninstalling Office 2011 again, I went back to Font Book to ensure that no fonts were corrupt. By running "Font Validation" from the File menu, I found that a few fonts were indeed corrupt, and a host of others (over 200) had warnings associated with them. I removed them all (easily done by selecting "Warnings or Errors" rather than "All" in the field at the top of the Font Validation window, and then selecting the "Select all fonts" dialog box below. I made sure to restart after that, before reinstalling Office 2011, and I also restarted after the install, while also repairing permissions between every step. Fortunately, this process worked.

    I'm not sure which of these steps is necessary (e.g., the fresh install), but I would surmise that the font weeding and font validation (removing all corrupt fonts and fonts with warnings) are necessary steps. I have not updated the Office 2011 install and am still running the base version, 14.1.0.
  10. Adam Tandy macrumors newbie

    May 20, 2013
    Fixed it for me. Microsoft obviously not a big fan of the Baroque period for some reason.

  11. somerandomdude macrumors newbie

    Mar 30, 2015
    Fix Worked

    Worked splendidly: OSX 10.9.5 Office 14.4.8 (had been running fine for a while) suddenly today none of the office programs would run until doing the above mentioned font 'weeding'- makes sense in retrospect that loading a font library would be common to starting all of the programs, but that and dozens of other things- kudos to whomever figured that out to begin with, too.

Share This Page