MM/Bluetooth problem? Read this!

Discussion in 'iMac' started by germanix, Apr 12, 2009.

  1. germanix macrumors member

    Apr 10, 2009
    Hannover, Germany
    Judging by this and other similar forums , it seems a lot of users of the new iMac and MacMini machines are having problems with the bluetooth keyboard and mouse. I just stops functioning. In an effort to „cure“ this problem forum users are offering all sorts of well meant advice. (none of which unfortunately solves the problem permanently) This advice ranges from:

    Reset the PRAM
    Reset the NVRAM
    Turn your Mac off and back on again
    Try deleting this file.

    If that doesn't help, make sure the batteries are charged. Go to System Preferences/Keyboard&Mouse. Click the Bluetooth tab. Your battery levels are displayed there. When it gets down to one green bar on the left, install new batteries.

    If none of the above helps, turn the mouse and keyboard off. Delete the mouse and keyboard from the System Preferences/Bluetooth devices window. Select the mouse in the window on the left, then click the minus - button. Now open the slider on the mouse so the green light blinks. Click + which will launch the Bluetooth Setup Assistant. Just follow the instructions. Same for the keyboard.

    Hook up a USB mouse, navigate to the BlueTooth icon on toolbar, and choose my Mouse & disconnect & reconnect, and then same with keyboard, and then they work immediately. (only to again stop working a few hours later)

    Remove the battery cover from the mighty mouse and bend the metal contact slightly outward.

    shut down my Imac, restart it, then go into BlueTooth preferences & delete the mouse & then "add" the mouse.

    One suggestion fromApple technical support:

    1. Shut down the system

    2. Disconnect at the mains

    3. Press the power button for 15 secs (discharges the motherboard?)

    4. Reconnect

    5. Immediately on pressing power up button, reset by pressing cmd-alt-P-R simultaneously (might need an extra hand to do this)

    6. Keep keys pressed until you hear two start up 'bongs' (restarts the bluetooth but problem keeps recurring – no solution)

    do the cmd-alt-p-r four finger salute.

    Facts are: None of the above is a solution to the problem. It only resets the bluetooth connection temporally, only for it to break down again later.

    As I have already said: This problem effects a lot of users all over the world. The forums here in Europe as well as in the States are full of complaints about this issue. What I find most amazing is the response of Apple to this problem. They chose to ignore it, probably in the hope that it will go away. When spoken to, they claim not to be aware of any problem, or they give some advice as those seen above which does not solve the issue, or they offer to replace the mouse only to send you a new mouse that also does not work. Apple seems to be treating their customers like mushrooms (keep them in the dark, and feed them sh*t)

    Well I have news for you Apple, this problem is not going to go away just because you choose to ignore it, and we the customers are not just going to sit there and allow you to treat us like mushrooms. What we want is action on your part. Starting by admitting that there is a problem and telling us what you are going to do to fix it, and when!

    My new iMac is due for delivery this week. I paid a lot of money for it, and I expect to get the quality product that I paid for. Should it arrive here and the mouse or keyboard does not function properly, or it has any of the other problems also mentioned on these forums associated with the new machines (yellow spot in center of display, display bright one side and dark on the other, overheating, fan noises, popping sound from speakers) etc, it is not just going back, I will cancel the buy altogether, and I will make sure everyone on the Internet gets to know about it and why.

    You want to sell your product for a premium price? Then make sure you deliver a premium product!
  2. Hellhammer Moderator


    Staff Member

    Dec 10, 2008
  3. gjw4u macrumors 6502

    Dec 2, 2008
    +1 with Hellhammer; forward to Apple / Steve Jobs.
  4. RichardI macrumors 6502a


    Feb 21, 2007
    Southern Ontario, Canada
    Yep, I've got a lovely little Bluetooth MM sitting on my desk, neatly tucked back in the box, waiting for a post somewhere that says the issue is fixed. Strangest part is, it worked perfectly for a long time before this happened. Bluetooth is actually a very old idea from IBM, no less. I have often wondered why Apple embraced it. Anyway, it seems there are more people who don't have this issue, than those that do. Maybe it's precisely that it is a random error (bug) that causes it not to be solved?
    Anyway, yep send it to Apple. I've got my fingers crossed.

    Rich :cool:
  5. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    I've got this issue but don't need all that complexity to fix it, just switch bluetooth off and then on again. Ironically I am doing this with a Microsoft usb mouse. Switching the MM off/on doesn't do it so it looks to me to be a bluetooth problem in the iMac.
  6. Sebby macrumors 6502a

    Dec 20, 2008
    London, UK
    Started getting this issue after initially no problems. Have today sent Apple feedback linking to the thread on their own forums - let's hope they get it sorted.
  7. jw2002 macrumors 6502

    Feb 23, 2008
    Bluetooth and 802.11b/g wireless overlap on the same 2.4 GHz frequency band, so there is great potential for the two protocols to interfere with one another, especially if you are using the "wide channels" setting in the airport extreme or time capsule. Use 802.11n wireless at 5 GHz to avoid interfering with bluetooth.
  8. James Cole macrumors 6502

    Jul 15, 2007
    San Antonio, Texas
    If I have a dual band AEBS how do I use the N option only?
  9. RichardI macrumors 6502a


    Feb 21, 2007
    Southern Ontario, Canada
    Does that apply to those who don't have Time Capsule, or Airport Base stations? I have just an iMac.

    Rich :cool:

Share This Page