MMS Issue - Post 4.3.1 Jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by guywoodman7, Apr 7, 2011.

  1. guywoodman7 macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #1
    So this is probably my own fault but I figured I may as well ask here to see if anyone has an easy fix before I restore my iPhone and start from scratch...

    So I jailbroke my iPhone 4 using redsn0w and all went well. However, I brought over my old SMS database file along with the folders "Drafts" and "Parts"...everything that was in var/mobile/library/SMS. I pulled these off my previously jailbroken phone that was on 4.1

    Soooo, everything works just fine and dandy, except for MMS messages. I will be alerted that I am receiving them, but basically an empty file appears with it in the SMS app. And the little blue arrow, that normally reveals the attached picture pointing to the right is all squished.

    I know a restore will probably fix it, but I was hoping someone may have an easier fix that will save me a few hours.

    Thank you!
     
  2. Gen macrumors 6502a

    Gen

    Joined:
    Jul 15, 2008
    #2
    Why not import from Restore after you jailbroke? To get all of your apps/data back?
     
  3. guywoodman7 thread starter macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #3
    Restoring from a backup on a jailbreak tends to create any more problems. I was hoping to find out a way to reset my SMS app to default hoping that would kick MMS back into gear.

    If no one else has any advice I'll be doing a new restore and not trying to bring back my old SMSs.
     
  4. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #4
    My MMS isnt working either.....no solution for this?
     
  5. krs7272 macrumors regular

    krs7272

    Joined:
    Sep 27, 2010
    Location:
    Detroit
    #5
    Mine wasnt either but I did a reset Settings, General, Reset Reset Network Settings fixed mine
     
  6. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #6
    Having this same issue after backing up SMS files, and tried this and no dice. So restoring old SMS databases.
     
  7. guywoodman7 thread starter macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #7
    I ended up fixing mine...but I'm not positive which solution worked...it was one of these 2.

    1-First i tried just trashing all the SMS folders and database files and letting The SMS app recreate them...that didn't seem to work at first, but I may not have actually quit out of SMS entirely before trashing the files. So I'm confident this woulda have worked properly if I had SMS completely closed and let it recreate it's necessary files.

    2-Then I ended up upgrading and jailbreaking my old 3GS I had laying around. Once it was nice and freshly jailbroken I just retrieved the "virgin" SMS files and put them on my iPhone 4. This ultimately worked but like i said, I may have screwed up initially in my first method above by not completely quitting out of the SMS app when doing this, so possible some multitasking files were kept which prevented it from working.

    All I all the lesson I learned is don't bother trying to restore your old SMS database. There has gotta be a proper way of doing it out there, but honestly I never go back on text conversations anyway so I don't care if I have the old convos.

    Just remember to save your MMS photos to your camera roll,
     
  8. supershick, Apr 19, 2011
    Last edited: Apr 19, 2011

    supershick macrumors member

    Joined:
    Jun 28, 2010
    #8
    Wow. I'm having the EXACT same problem as you OP.

    I can't send or receive MMS and when I do receive the MMS, it's a squishy arrow. When I tap the arrow, there's no picture. It's a blank screen.

    I tried the above mentioned 'Reset Network Settings' but that didn't work. I tried downloading new APN settings and that didn't work either.

    I have a iPhone 4 and PwnageTool'ed it to 4.3.1.

    Any other ideas what might be happening?

    My permissions on the SMS folder 700 with ownership as mobile:mobile. See any problems with that?
     
  9. JosephBlowinsky macrumors newbie

    Joined:
    Dec 15, 2009
    #9
    I was unable to send or receive MMS after my 4.3.2 Jailbreak

    I have been fighting it all night, just removed ultrasn0w 1.2.2 and resprung

    and immediately after coming back up, I received multiple MMS tests I had asked others to send earlier in the evening

    I was able to send two test MMS messages with pictures as well
     
  10. badlt1 macrumors newbie

    Joined:
    Jun 16, 2009
    #10
    MMS not working for me either 4.3.2

    Jailbreak but no unlock, everything working except unable to send or receive MMS messages.
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    Im on 4.3.1 and bb 01.59.00 with ultrasnow and using AT&T. Usually when MMS goes down all I gotta do is pop out the sim tray and stick it back in a few seconds later and it starts working again.
     
  12. iLoyal macrumors regular

    Joined:
    Nov 18, 2010
    #12
    I have the same issue with OP, but my iP4 is factory unlocked. I tried asking a employee that works in a T-mobile store and unfortunately he turned me down by saying "It's a long process and you need to call the customer support."....
     
  13. jrk macrumors newbie

    Joined:
    Jan 30, 2005
    #13
    iPhone 4, iOS 4.3.1 with Pwnage Tool and ultrasn0w, baseband 01.59.00. MMS send/receive (and, I just noticed, voicemail notification) broke after iOS 4.1 ==> 4.3.1.

    Reset Network Settings worked like a charm. (And promptly informed me that I've ignored 7 voicemails in the past month.)
     
  14. StevePenny macrumors newbie

    Joined:
    May 21, 2011
    Location:
    UK
    #14
    Hi all,

    Hoping somebody can offer me a bit of advice regarding this MMS issue - will try to keep the details as brief as possible....

    Factory unlocked iP4. All features previously worked fine. Jailbroke phone after a few months & had a few issues with the camera roll, so made copies of all my essential data (including the SMS folder as mentioned above), cleared the phone down, put data/folders back & re-virginised.
    Since then I have had the same MMS issue. Assumed it was a carrier/account issue as I only noticed it when I changed from o2 to Vodafone. Vodafone have done all checks & state it's the hardware/software. ........ So does anyone know of any way I can fix this issue without re-jailbreaking? If I eed to re-jailbreak to change/update the above-mentioned folders, could somebody please provide me a bit of a step-by-step guide at all, please? I don't want to mess anything else up!!!!

    Hope somebody can help!! & thanks in advance for any advice.
     
  15. hankydysplasia macrumors newbie

    Joined:
    Apr 24, 2009
    #15
    I'm wondering if anyone has figured this out yet.

    I've updated to iOS 5 beta 2 and am still having the problem.

    Really aggravating!
     
  16. thizzinG macrumors member

    Joined:
    Aug 4, 2010
    Location:
    West Coast, Cali
    #16
    Ever since I have updated to 4.3.3 since the jailbreak came out my MMS have been defunNKT.

    Resetting networks settings doesn't work either.
     
  17. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #17
    Whenever I receive MMS messages I get "Content cannot be received because your handset cannot display it."

    What does this mean and is it the same thing we're talking about here?

    I'm running an iPhone 4, 4.3.3 on the standard baseband for that firmware. Jailbroken with redsn0w.

    UPDATE: I can send them and they are received by my recipients. I simply can't receive MMS. What's the deal?
     
  18. guywoodman7 thread starter macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #18
    I wasn't that clear in my post above (#7), but from all my tinkering it seems that just restoring the main SMS folders/data is whats messing everything up. When I got rid of my restored SMS data, everything started working again. Yes I no longer had access to my old SMS logs and pictures, but at least everything is working again.

    So for anyone still having this issue...completely quit out of your SMS app, then try trashing the existing SMS folder and try again. When you launch the SMS app, it should recreate any missing folders and everything should be good. It worked for me.
     
  19. elKabongXXI macrumors newbie

    Joined:
    Jul 8, 2011
    #19
    Having MMS problems, too. I just got a refurb replacement of my 3GS and JB w/redsn0w. It came "stock" from the Apple Store with 4.3.3. I restored my old SMS folder from a manual backup, too. I just recently noticed that I cannot send pics via MMS. I can receive them fine now; although, last week I had the issue of the 'squished' arrows w/no content. I can send text ok, just no pics. I can attach them, and it will look as if they are being sent, but the 'sending...' progress bar stops short of completion and just sits there. Nothing ever gets sent.

    I talked at length with AT&T this evening - they thought it might have been an IMEI issue (they still had my old one in the system); but, after updating that on their end, still no dice. Tried resetting network settings several times - nada.

    After reading this thread, I tried quitting the messaging app and dumping my SMS folder via iFile, then letting iOS create a fresh folder and sms.db. I still have the same problem, even with a freshly created database - can't send pics. I even compared the permissions settings of the new SMS that iOS generated, and they were the same as my older ones that I had manually backed-up and restored via iPhoneBrowser.

    This is REALLY FRUSTRATING, and I don't want to have to do a fresh restore of my firmware, as I'm not even sure THAT will work. Surely, there's GOT to be some simple tweak/fix to make this work, as I can get pics - I just can't send them. Any more ideas, anyone?

    --eK :confused:
     

Share This Page