MMS Issues

Discussion in 'Jailbreaks and iOS Hacks' started by bendrucker, Mar 14, 2010.

  1. bendrucker macrumors newbie

    Joined:
    Mar 14, 2010
    #1
    I'm having some problems with MMS. I can send and receive MMSs to myself. I can also send MMS messages to an email address. But when I try to send an MMS to another phone number, it just goes about 90% of the way on the progress bar and then hangs and never sends the message. When other people try to send me MMS messages it just appears as a blank space with the blue arrow next to it. Any ideas why this could be happening? It's a software issue for sure, since when I recently restored my iPhone and didn't restore the settings it started working again. But now it's stopped working.

    I'm using an iPhone 3GS on 3.1.2 jailbroken with blackra1n.
     
  2. jayo1971 macrumors member

    Joined:
    Jun 11, 2009
    Location:
    Nottingham
    #2
    MMs Problems.

    I have been having the same problems too. Very strange, i thought it was just me.
    It must be a network thing which i hope they will sort soon.:mad:
     
  3. IBradMac macrumors 68000

    IBradMac

    Joined:
    Jun 27, 2008
    Location:
    Ohio
    #3
    How many bars do you have when this happens? Are you attempting to send over Edge or 3g?

    I notice when I try to send an MMS with 2 bars or less on Edge it often fails and takes many attempts to finally work.

    Edit; your jailbreak is likely not the culprit...
     
  4. Vandam500 macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #4
    You can try updating your carrier settings via iTunes. Remember its your carrier settings, not your firmware.
     
  5. bendrucker thread starter macrumors newbie

    Joined:
    Mar 14, 2010
    #5
    I am trying this with four bars and 3G. I've also tried it from multiple locations and weeks apart so it's certainly not a temporary or location-specific network issue. I will try forcing an update to the carrier settings and report back.
     
  6. bendrucker thread starter macrumors newbie

    Joined:
    Mar 14, 2010
    #6
    It gets weirder...

    I remembered that in addition to pictures there's other things that can be sent via MMS, namely vCards and Voice Memos. So I went and send a vCard to someone and voila, it's sent off without a hitch. But when I try to send a picture to the same person, no dice. Then I tried a voice memo. Again, it went through. So it seems it's only pictures and videos that I can neither receive nor send.
     

Share This Page