MMS not working. 4.0.1 culprit

Discussion in 'iPhone' started by chris.robison, Jul 21, 2010.

  1. chris.robison macrumors regular

    Joined:
    Feb 16, 2009
    #1
    Hello. I've had my iPhone 4 since yesterday and love it. I haven't been able to use voicemail or MMS. I waited til today then contacted AT&T. I found that voicemail didn't work because I had Cellular Data disabled. MMS still doesn't work though and the rep told me that this is a known issue with 4.0.1 that Apple will be addressing soon. When I try to send a picture message, it hangs at about 90%.

    Has anyone else had this problem? I've reset the phone, reset network settings and tried on both 3G and Edge to no avail.

    Searching around I didn't see any thing related to MMS and 4.0.1. Maybe its something else?
     
  2. Mliii macrumors 65816

    Mliii

    Joined:
    Jan 28, 2006
    Location:
    Southern California
    #2
    I haven't read about that one anywhere...not saying it ISN'T necessarily a known issue, but it's not known on this message board!;)
    Sometimes the good folks at AT&T Customer Service have so little genuine knowledge that they will tell you anything to get you off the phone with them. Not all of them, mind you, but many!
     
  3. chris.robison thread starter macrumors regular

    Joined:
    Feb 16, 2009
    #3
    Yeah I'm wondering if that's the case. I did chat support and usually get good results through it.

    I'm on these forums quite a bit lately and haven't seen this yet. Hmm. I wonder what's up then.
     
  4. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #4
    While the things AT&T say might be nonsense, I remember reading this a few weeks on the O2 UK website:


    My understanding is that the Carrier Settings file of each carrier allows them to state whether or not Visual Voicemail (and presumably MMS) should be enabled when data roaming (and presumably now the "cellular data" toggle) is set to off.

    For some reason, iOS4 has changed that intended functionality and Apple has told carriers that they plan to change it back.
     

Share This Page