MMS not working on 3GS with iphone 2g plan

Discussion in 'iPhone Tips, Help and Troubleshooting' started by phantoms, Sep 28, 2009.

  1. phantoms macrumors member

    Joined:
    Jul 23, 2009
    #1
    Hey guys i have the new carrier 5.5 and also am on 3.1 and my mms does not work. my buddies does with his 3g on a 3g plan though. i have the icon and i can add the picture in but it fails at the very end around 95%. I am on the iphone 2G plan still (a fight to keep it) for unlimited data and 1500 text for 30 bucks. i also restarted many times. tried the turn wifi off and 3g off still no luck.

    even when mms are sent to me i still get that message saying bla bla has sent you a multimedia text and i have to goto the website to see it.

    is this not working because i am on an old plan or for some other reason? i know iphone 2g users dont get mms but its just the plan??

    thanks
     
  2. Macjames macrumors 6502a

    Joined:
    Dec 12, 2007
    Location:
    Yorkshire, England
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7C144 Safari/528.16)

    O2 rep told me I needed a new sim when I went from 2g to 3g so I would imagine the same applies for you. Unfortunatly you would not be able to keep your 2g plan
     
  3. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #3
    They do this because they claim you need a new SIM for the different network but it's a load of crock.
     
  4. phantoms thread starter macrumors member

    Joined:
    Jul 23, 2009
    #4
    My sim is new got it with the 3gs I got the 2g plan by giving AT&T A imei from a 2g phone
     
  5. rjohnstone macrumors 68040

    rjohnstone

    Joined:
    Dec 28, 2007
    Location:
    PHX, AZ.
    #5
    And there lies your problem.
    2G iPhones do not qualify for MMS service, so AT&T blocks MMS service for these plans.
     
  6. phantoms thread starter macrumors member

    Joined:
    Jul 23, 2009
    #6
    I mentioned that in the first post, I thought it was hardware that was why it didn't work? And how come they don't block 3g also then?
     
  7. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #7
    Because Apple chose to enable MMS for the 3G and disable it on the 2G. That's all.
     

Share This Page