MMS not working on iPhone 4

Discussion in 'iPhone' started by bobright, Jul 29, 2010.

  1. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #1
    So I thought we were allowed to receive MMS and it would show up as a picture?

    Well when I get a picture text it sends me to viewmymessage.com/1 and not only that I type in a ID and Password and no picture shows up. It has a link that says "replay" but no picture.

    What is going on??
     
  2. ref26 macrumors 6502a

    ref26

    Joined:
    Mar 13, 2008
    #2
    It works fine for me, maybe the person sending it doesn't want to pay for real MMS?
     
  3. TruckdriverSean macrumors 6502a

    Joined:
    Feb 28, 2009
    Location:
    Texas, US
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    What OS version is your iPhone running!?

    Maybe a carrier glitch?
     
  4. Roessnakhan macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    ABQ
    #4
    Did you try that iPhone 2G > iPhone 4 unlimited data trick? I only ask because that's how MMS messages were delivered on the 2G. Dunno if its the reason, just speculating.
     
  5. bobright thread starter macrumors 601

    Joined:
    Jun 29, 2010
    #5
    I am running the current fw 4.0.1 and am grandfathered to a Unlimited plan.
     
  6. Lifesuxsbad macrumors regular

    Lifesuxsbad

    Joined:
    Jun 15, 2010
    #6
    Mms

    Mine works like it did on my 3G..get someone else to send you a picture and see if the same thing happens from their phone.
     
  7. Block macrumors 6502a

    Block

    Joined:
    Jun 28, 2007
  8. jlpoore89 macrumors 6502

    Joined:
    Feb 16, 2009
    Location:
    Beaumont, Texas
    #9
    Did you make sure that the MMS setting is turned on? I found that when I got my iPhone 4 even after restoring from a backup it was turned off by default. It's in Settings>Messages>third setting down.
     

Share This Page