MMS not working

Discussion in 'iPhone' started by davidpace, Jul 17, 2010.

  1. davidpace macrumors newbie

    Joined:
    Jun 8, 2010
    #1
    Hi all, I have been having problems with MMS on my iPhone 4. I just upgraded the software to 4.0.1 so I don't know if that has anything to do with it. I cannot send or receive picture messages. I had a similar problem when I first got the phone but I solved it by switching "Cellular Data" ON (did not know b/c it's my first iPhone). Anyway, has anyone else had this problem and know how to fix it?
     
  2. Tito Georgie macrumors 6502

    Tito Georgie

    Joined:
    Jul 17, 2010
    Location:
    New York
    #2
    Same here, girls are getting mad at me because they're having to email me the pictures. :mad:
     
  3. Daddy Mac macrumors member

    Joined:
    Jun 9, 2010
    #3
    Yea I have the same problem. I can send pictures perfectly with PingChat but with regular MMS it just doesn't go through. I get a little red exclamation mark.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Call up AT&T and make sure everything is right on their end.
    They will troubleshoot and figure it out.
     
  5. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #5
    had the exact same problem called Rogers from a different phone they kicked me rom their network and connected me back on whilst my phone was off and i could send receive messages again.
     
  6. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #6
    Usually, it's nothing to do with the 'phone - it's the network.
     
  7. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #7
    just so that we can troubleshoot the issue, is the MMS feature 'Turned On' on your phone?

    Settings ->Messages
    [​IMG]
     
  8. davidpace thread starter macrumors newbie

    Joined:
    Jun 8, 2010
    #8
    It is working now. I turned off "Enable 3G" and turned it back on, and did the same with the "Cellular Data". MMS works great now. Thanks.
     
  9. KGWVU macrumors regular

    KGWVU

    Joined:
    Jun 15, 2010
    #9
    Also, remember that pictures taken with the iphone 4 have a higher resolution and subsequently, a much larger size. Where before you could send a 3G or 3GS photo fairly quickly, it will take longer with the 4 and possibly time out if you are not getting a strong signal.
     

Share This Page