Resolved Mobee magic charger problem

Discussion in 'Mac Accessories' started by Kashika, Jun 3, 2011.

  1. Kashika, Jun 3, 2011
    Last edited: Jun 9, 2011

    Kashika macrumors regular

    Joined:
    Sep 8, 2010
    #1
    I just got my mobee magic charger in and I cannot get it to fit my magic mouse.

    The back part of the rechargable battery pack will not fit my mouse perfectly. It's the part with the tiny button you pull when attempting to take the top part off so you can replace the batteries.

    Is there anyone who can help me with this, or someone who can tell me how to install the battery pack?

    Edit: I think I got it to fit, but now there is a tiny part sticking out. That part scratches any surface it's on because it sticks out beyond the teflon skids on my mouse.
     
  2. KlytusLord macrumors regular

    Joined:
    Apr 11, 2011
    #2
    This is a common problem, and you may want to search YouTube for one of the many demonstrations on it.

    I amounts to this: you have to use a lot more force than you would think, and yes, it feels weird to be that tough on the mouse, but eventually it clicks into place properly.

    Another thing that is well known is that the battery pack does stick out the slightest bit more that the original battery cover. Mobee even has an explanation about that on their site, but it should not be scratching any surface or interfering with the smoothness of the mouse motion.

    Check out the videos, they do help. It took m a while to get mine to fit properly, but I finally got it, and everything works great.
     
  3. Kashika, Jun 3, 2011
    Last edited: Jun 3, 2011

    Kashika thread starter macrumors regular

    Joined:
    Sep 8, 2010
    #3
    I have searched and cannot find this problem with a lot of detail.

    My battery pack is fitting, but I do have the problem of that tiny part sticking out beyond the skids. Applying force does not help here, the battery pack won't go in any further.

    I have attached some pictures to show what I mean.

    After comparing it to some video's on youtube it seems to me that somehow that part only sticks out on my battery pack. Others do not have that, which makes those fit better. And yes it also looks like that should I take the battery pack out.
     

    Attached Files:

  4. Kashika thread starter macrumors regular

    Joined:
    Sep 8, 2010
    #4
    I have been offered a replacement. My question to someone who has this exact same charger, will this make a difference?

    Since I do not know if I will experience the same problem. I looked at several video's which don't have that tiny part sticking out. So I'm not sure if I just have a faulty unit, but it seems likely though.
     
  5. Kashika thread starter macrumors regular

    Joined:
    Sep 8, 2010
  6. Kashika thread starter macrumors regular

    Joined:
    Sep 8, 2010
    #6
    Got a replacement. It appears the cover was faulty. This one fits perfectly and doesn't scratch any surface or sticks out.
     
  7. Yeziam12 macrumors newbie

    Yeziam12

    Joined:
    Jun 9, 2011
    Location:
    Texas
    #7
    Battery Cover Tab

    I just received my new Mobee Mouse battery pack and it has the same problem as noted here. The latch (tab) at the bottom of the battery pack, basically went the "wrong way", the battery pack as a result was slightly ajar at the bottom, and that tab was scratching my mousepad. After fiddling with it, I just took off the tab and the battery pack is staying in place anyway. So for now, if it stays in place, I'm content. FYi/Yez
     
  8. asamax, Oct 8, 2013
    Last edited: Oct 8, 2013

    asamax macrumors newbie

    Joined:
    Oct 8, 2013
    #8
    coil unwelded

    New in town. I've got my troubles with magic charger and I solved it.
    Please move this post if unproper.

    Red light blinking, thus not charging. While I kept the cable connector plugged evil in, it turned green: charging.
    Cable issue? Connector issue?
    Opened the unit with a thin screwdriver (the white plastic opaline surface can be pulled out). It's stuck in just by a little glue, easy to detach.
    Then dismounted the pcb, no troubles.

    There's the coil which charges the mouse by induction. One of the two tips was unwelded. Maybe pressing the unit just made the circuit get closed, that's why it occasionally worked.
    Welded that tip, everything got working. Hope this helps.
     

Share This Page