All iPads Mobile device repair technician here, deep trouble with an iPad 3 repair.

Discussion in 'iPad' started by alexthealex, May 4, 2013.

  1. alexthealex macrumors newbie

    Joined:
    May 4, 2013
    #1
    Hello forums, long time lurker, but I made an account to ask some advice. I repair Apple mobile devices every day for a living. We're a non-accredited local-owned repair shop that specializes in apple mobile device repair. I'm fixing an iPad 3 right now, glass repair, which is pretty straightforward. After putting the new glass on, the power button wasn't working. The rest of the flex worked fine, hold and volume that is, but not the power button. Since damaging the power flex is pretty common in glass removal, I didn't think much of it, grabbed a new flex, and replaced it. Still a fail. Tried with yet another part to check for coincidence, and still a fail. Every other aspect of the device works fine, wifi, cameras, touch sensitivity, and I can lock the screen with assistive touch. I've "hard reset" the device manually by lifting the board off the battery contacts, and checked for visible damage to the thin strip of board that connects to the top mic, cameras, and flex. All looks good. Does anyone here have any advice?!:confused::confused::(
     
  2. paulbennett95 macrumors 6502a

    paulbennett95

    Joined:
    Aug 30, 2012
    Location:
    Long Island, NY
    #2
    When you say the power button doesn't work, do you mean just the button doesnt work or the iPad doesn't turn on at all.

    I realize you're a technician and I'm not, but if it won't turn on, see if the battery is connected and functioning.

    If its just the button, idk then, I'm no technician :p

    Good luck.
     
  3. alexthealex thread starter macrumors newbie

    Joined:
    May 4, 2013
    #3
    It powers up fine, but when it's off without the power button functioning you have to plug it in for it to power up. There's no way to turn it off other than to let the battery die.
     
  4. temna macrumors 6502a

    temna

    Joined:
    May 5, 2008
    #4
    Silly question. Could there be a piece of something in the way of the power switch itself? A physical issue with the power switch?
     
  5. alexthealex thread starter macrumors newbie

    Joined:
    May 4, 2013
    #5
    Nah. I've pressed the button both without fully installing it (bypassing the exterior button) and installed, and it clicks properly.
     
  6. pragmatous macrumors 65816

    Joined:
    May 23, 2012
    #7
    I'm not a technician but I am an (systems) engineer. My advice is don't assume it looks good and the most complex problem is usually something simple. So back track from the beginning and start thinking of stupid stuff you didn't check. Things you swear could never break? Ya it might be broken. It's best to double check.

    Throw enough darts at the wall and eventually one will stick. Please keep us updated on this. I'm curious now on what the issue is.

    Could there be something shorting out the power button?

     

Share This Page