Mobile iTunes Library and a Local?

Discussion in 'Mac Apps and Mac App Store' started by iMerlin, Sep 29, 2009.

  1. iMerlin macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #1
    Hello everyone, here's my thing...

    I have a MBP that I take to work with me every day. I like listening to iTunes at work and at home. I have a pretty large library so I moved the library from my MBP to a nice 500gb external HDD. So while Im at work, I plug it in and poof, Im off and running with my tunes.
    I keep a copy of that library on my home server also.

    Now here is where I get lazy. At home, Im much more mobile with my MBP. I take it on the deck, I have it in the basement, I bring it to the kitchen, garage, ect... I dont like carrying the external HDD around all over the place.
    So recently I opened iTunes using the Option-click command and selected my home server as the location for the library. The very same library I keep a copy of on the external. iTunes gave me an error about not having a library file in that location. So I copied the library file from my external to my server and tried it again. iTunes loaded up but...
    1. Im missing 50% of my artwork, artwork I spent a while collecting.
    2. When I switch back to my external drive, iTunes gives me the same error from above. So I have to copy the library file to my external drive from my server and then back again when I want to switch again. (Hope that makes sense.)

    So I guess Im wondering how other people in the same situation handle this? Ive read posts where people mention having a mobile library and a local one, how do they accomplish this?

    Thanks ya'll!
     
  2. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #2
    Anyone? Bueller?

    So I cant get back my artwork and its pissing me off! I spent so much time getting all my cover art, now half is gone. I dont get it. All I did was moved my library file from one external drive to another and poof. Even if I move it back to its original location I still dont have my artwork back. I may have corrupted the file or something.

    Anyway, Im sure someone out there has a situation like this. How can I embed the artwork into the file itself so I dont have to worry about this again?
     
  3. drewster macrumors member

    Joined:
    Aug 4, 2008
    #3
    I used to battle with the same problem, library bigger than HD.

    Which really begs the question, why fight it? For about a Benjamin you could probably get a TB drive?
     
  4. littledude8209 macrumors regular

    Joined:
    Jun 18, 2009
    #4
    I've never had this problem, because even if I take a song, put it on my psp or a flash drive and onto another computer the album artwork seems to still be there >_< maybe something in the preferences?

    but as far the the library file goes, why don't you just duplicate it (option click, duplicate file) and then you'll have one for your server and one for your mac!
    hope I helped :]
     
  5. iMerlin thread starter macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #5
    Well my home server is a 2TB Drobo, but thats not portable at all. So I decided to keep another copy of the library on my 500GB external drive. Maybe I just need to drop the cash for the internal 2.5" 500GB drive for my MBP!

    I did the duplication, but for some reason when I Option-click to open it from the server instead of the external drive I still lost my artwork. I had to rescan for art, it found some of it but not nearly all of it. Not sure why it isnt following the files. Maybe I corrupted the file.
     

Share This Page