Mobile Me Calendar Events not syncing to iCal

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by danielforman, Sep 3, 2008.

  1. danielforman macrumors regular

    Joined:
    Sep 29, 2007
    #1
    Been having a strange problem just lately when syncing with Mobile Me.

    If I create a Calendar event on the Mobile Me web interface or on my iPhone it won't appear in iCal when a sync occurs either automatically or manually on my mac. However, if I create an event in iCal it will sync up to Mobile Me and appear on the web interface and on my iPhone.

    Not having any problems with contacts etc just that one problem with the calendar.

    Anyone got any ideas on how to fix this. I have done a search of these forums and couldn't find anything same with Apple Support discussions and a general google search. Have also reset sync data in both directions so from mobile to my mac and from my mac to mobile me with no joy. Have also cleared the iSync history as well and disabled entourage sync as it was crashing and causing the mobile me sync to take ages.

    Thanks for any help
     
  2. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #2
    Your changes on your phone or mobileme web will not sync to your iCal for 15 minutes or more depending on your last sync time.

    Have you checked your mobileme settings in system preferences?
     
  3. danielforman thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #3
    Does this apply if i do a manual sync from within the Mobile Me preferences section?

    BTW: Forgot to mention in the first post but I also use Mobile Me with Outlook on my PC and it was showing events created on the iPhone and Mobile Me web interface ok and any events created in it were appearing on my iPhone and Mobile Me and that was after either an automatic sync and manual sync from the preferences dialog located in control panel.

    So everything is working ok except new events not appearing in iCal unless I create them in there.
     
  4. Maagus macrumors regular

    Joined:
    Nov 7, 2007
    Location:
    Czech republic
    #4
    I didn't want to start a new thread but I am having the same problem. My setup is : iPhone - MobileMe - Macbook. Everything sync OK (contacts, e-mails are being pushed etc.) except iCal. When I create new event on iPhone it shows in MobileMe but it won't sync to Mac. I have tried resetting sync data, syncing manually and automatically but without any success, events created on iPhone won't appear in desktop iCal. I am quite annoyed by this because iCal is my main event and assingments organizer :(
     
  5. danielforman thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #5
    I have tried everything I can think of including resetting sync data, clearing iSync history, creating a new user account on my mac and setting up mobile me, clearing everything out of iCal, clearing everything out of Mobile Me calendar and nothing works.

    So I have emailed the Mobile Me support team and am waiting for a reply so if I get a solution from them that works I will post it up here.
     
  6. MacLou macrumors newbie

    Joined:
    Sep 5, 2008
    #6
    same problems

    when i try to sync it says inconsistant data. I chat person told me that my info in the cloud is corrupted. When i told him it was the accurate calender i was told to enter on ical all events and then they could erase the mobile me info.
     
  7. Rivix macrumors 6502a

    Rivix

    Joined:
    Oct 13, 2005
    #7
    I sometimes have the same problem. For instance when I add a new event on my iPod Touch, it will never show up on iCal and in some cases gets deleted so I have to enter them again. I might have done something wrong, but it would be nice to know what it is.
     
  8. gwerhart0800 macrumors 6502

    Joined:
    Mar 15, 2008
    Location:
    Loveland, CO
    #8
    Ditto ...

    I am probably not a typically user, but I have a 1st Gen iPhone, a 3G iPhone, a Mac Mini and a MacBook Pro all syncing with the same MobileMe account. I can enter events on either of the iPhones and they show up on the other within a reasonable amount of time. The Mac Mini syncs without any error messages, but does not get the calendar changes. The MacBook Pro refuses to sync and tells me to reset the calendar, but never works regardless of what I do. (resetting does not help, nothing does.)

    I typically enter calendar events from one of the iPhones while I am sitting in a meeting, but I typically review my schedule on one of the Macs ... I have tried cutting things back to one Mac and one iPhone, but it still does not work.

    My trial account runs out in December ... I am hoping that MobileMess reaches the "just works" stage before then. I really do want to keep MM, but I don't want to pay for an unreliable service.
     
  9. Phizz macrumors newbie

    Joined:
    Feb 14, 2008
    #9
    Same problem .. think it may be an OS X 10.5.5 fix (hopefully!)

    I have the same scenario - creating calendar events on iPhone show up on web but not on iCal. Also, creating events on web show up on iPhone but not iCal. Finally, creating an event in iCal does actually show up on both web and iPhone, but changes made to that event on web or iPhone do not get synced back to iCal.

    I think this is an iCal problem, not a MobileMe problem. I believe there is a "MobileMe data-store" which exists on my Mac that does indeed contain the correct data from MobileMe, but an error occurs when this data is attempted to be written into iCal. I believe this, because I do successfully get the dialog box warning about "more than X% of my calendar events changing with this sync" after making calendar changes on the iPhone or Web, but then when I sync again, I do not get this dialog - i.e. the data has successfully been copied and no changes are detected.

    So what's happening when data is attempted to be copied from my local MobileMe data-store into the iCal calendars? Well, every time I sync with MobileMe, the following errors show up at the exact time of sync in Console.app:

    12/09/2008 21:32:30
    iCalExternalSync[13303]

    SyncServices precondition failure in [ISyncConcreteSession clientAcceptedChangesForRecordWithIdentifier:formattedRecord:newRecordIdentifier:]: you can't change the record identifier from 3F804FA4-D0F8-44D6-812C-DE74D1D5ED82 to com.apple.ical.calendars.RootNode: it is already associated with a different record.


    12/09/2008 21:32:30
    [0x0-0x30a30a].com.apple.iCal

    2008-09-12 21:32:30.670 iCalExternalSync[13303:10b] SyncServices precondition failure in [ISyncConcreteSession clientAcceptedChangesForRecordWithIdentifier:formattedRecord:newRecordIdentifier:]: you can't change the record identifier from 3F804FA4-D0F8-44D6-812C-DE74D1D5ED82 to com.apple.ical.calendars.RootNode: it is already associated with a different record.


    These 2 errors appear three times each - I guess for each of my three calendars.

    I googled galore about this one and found a few similar references to these error messages, but no fixes. Hence my title - I see iCal is listed as one of the focus areas on the ongoing testing of OS X 10.5.5. Let hope this issue is fixed! The fact that they extended MobileMe subscriptions by a further 60 days on top of existing extensions also leads to me to believe that Apple knows it is taking a while to get every last issue ironed out, this being one of them. Pain in the meantime!
     
  10. cfs macrumors 6502a

    Joined:
    Feb 8, 2008
    #10
    I am using a mac but am having a similar issue. Craeting events on Touch or computer sync with each other, but nothing happens on the web.
    -cfs
     
  11. danielforman thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #11
    That is the exact same type of message I am getting up in console.app when I sync.

    Since posting this message first I have done an archive and install of OS X and a clean install with no joy. I got a mate of mine to sync my mobile me calendars to his iMac and they appeared ok in iCal but he is using 10.5 without any updates as he just got the mac.

    I am currently waiting for a reply from Mobile Me support and both myself and the Mobile Me support guy have been trying numerous things. He even created a test account for me to sync to but it made no difference as it happened on that as well. The MM Support guy also synced my Mobile Me calendars to his test mac and he had the same problem with the not appearing in iCal so it does seem to be a very strange problem.

    The calendar data seems to be getting down to my mac from mobile me just not appearing in iCal as if I reset sync data from my Mac up to mobile me then all events even those created on my iPhone or the web interface will sync up from my Mac. So the data must be stored somewhere, it's just not getting to iCal from iSync by the look of it.

    But as you say if it is an OS X issue and not a web issue then hopefully we will see a fix in 10.5.5 and hopefully it will be available soon.
     
  12. Phizz macrumors newbie

    Joined:
    Feb 14, 2008
    #12
    Well I've just updated to 10.5.5 and this issue is still occurring.

    After installing update:

    Tried it as normal - still won't sync
    Tried resetting sync data in MobileMe advanced pref pane - still won't sync
    Tried resetting sync history in iSync - still won't sync
    Tried deleting all iCal data from Mac - still won't sync
    Tried a combination of the above - still won't sync

    Still receive the exact same Console errors.

    Well, with the extensions, it seems I have 69 days left of MobileMe trial. So if 10.5.6 isn't released by then (and fixes this issue), I guess it's goodbye MobileMe.

    Unless of course anybody out there can help??

    EDIT: Actually things have got worse. Just logged into me.com and my calendars are missing from the list on the left (it's just blank). Also the calendar colours online seem to have changed ... wtf. Really how hard can it be to get simple basic functionality to work. C'mon Apple get with it.
     
  13. gwerhart0800 macrumors 6502

    Joined:
    Mar 15, 2008
    Location:
    Loveland, CO
    #13
    Ditto for me ... 10.5.5 does not fix calendar sync problem

    I have tried every trouble shooting procedure. What I find ABSOLUTELY amazing is that creating a brand new user with an virgin iCal (never opened!) still fails to sync. Why, Why, Why can't the damn MobileMess software just NUKE my Mac iCal calendar and download everything from the bloody cloud!!!!!

    How can Apple expect people to pay $$$ for this crap ...
     
  14. danielforman thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #14
    I too have updated to 10.5.5 and was hoping it would fix the problem but unfortunately it hasn't. I also have the problem where calendars don't show down the left on the Mobile Me Web Interface and at the moment I get the error message Mobile Me is unable to load your calendar.

    I have emailed the MM Support team about this and at first got the low level customer support reps who suggest the usual KB articles to try. But now it has been escalated further and is with one of the MM Specialists. I have been trying things my end that he has suggested and what I think might be worth looking at and he has tried things his end. Thankfully I am not heavily reliant on Mobile Me calendars and I can manage at the moment entering all my events into iCal and for them to sync up. But is still annoying and for those who rely on this feature will be even more annoying.

    If I have success getting mine to work I will post a solution that might work for you guys as well as soon as.
     
  15. franzmueller macrumors regular

    Joined:
    Dec 1, 2007
    Location:
    Spain
    #15
    Hi

    I´m glad i´m not the only one around .....

    My push ( or Fetch ) ical is not working at all since day 1 ... ical works fine between my 3 laptops thru idisk but it just dosen´t work with my ipod Touch / iphone / Macbook unless i sinc them manually ( connecting the devices to the computer ). and i have all software updates . Tried EVERYTHING .... gone thru all information , manuals etc with no luck.

    I guess i´ll keep getting free subscription till Apple finally fix it .. cause i´m not going to pay one single penny until it dosen´t work properly :p

    Saludos
     
  16. Polancito macrumors newbie

    Joined:
    Sep 22, 2008
    #16
    Found this on other site

    This did it for me, happy to share...


    Thanks to "The Shadow"

    I got this from the Apple Discussion forum. I had emailed it to myself so I could do the necessary changes at a more appropriate time. I have done the changes and they work. Getting the email to push...that's another story.

    Here are those instructions:

    --
    1. Sync your iPhone via USB to iTunes.
    2. Turn Off Your iPhone.
    3. Wait 30 seconds and turn it back on.
    4. Tap on "Settings" icon
    5. Tap on "Mail, Contacts, Calendars"
    6. Locate your Mobile Me Account
    7. NOW THIS STEP IS CRUCIAL!!! Make sure that under the MM account name it looks exactly like this: Mail, Contacts, Calendars, Bookmarks
    8. If it DOES NOT HAVE ALL OF THESE ITEMS LISTED your MM WILL NOT SYNC correctly.
    9. Follow this simple fix: DELETE THE MOBILE ME or .MAC Account on the
    iPhone.
    10. Once Complete TURN OFF YOUR IPHONE AGAIN.
    11. Wait 30 Seconds and TURN BACK ON
    12. Tap on "Settings"
    13. Tap on "Mail, Contacts, Calendars"
    14. Tap on "Add Account"
    15. Re-Ad you Mobile Me Account
    16. Make sure your "Fetch New Data" icon is set to "Push"
    17. Once you enter all the info in for your Mobile Me Account SAVE it
    18. Mobile Me will run the verification
    19. Now tap on your NEWLY ADDED MOBILE ME ACCOUNT
    20. Make sure that Mail, Contacts, Calendars and Bookmarks are all set to "ON"
    21. Mobile Me will do the initial "CLOUD" sync May take up to 5 minutes
    22. Everything will begin to work. Try adding a contact on your iPhone or update your iPhone Calendar. Within 1 minute your Mobile Me On-Line Account and Desktop Contacts and iCal Calendars will update.
    --

    NOTE: This may or may not work for you. It has worked for me and a couple of family members having the same problems.

    Good luck.

    http://www.ehmac.ca/ipod-itunes-iphone-apple-tv/68811-iphone-not-syncing-calendar-events.html
     
  17. londondude macrumors regular

    Joined:
    Nov 13, 2007
    #17
    the only way i can get anything i add in iphone/mac to show up in outlook calender is to put it to re-occur for 1 year and to end on the date of the occurance (so it doesnt re-occur but is notes as re-occuring). this then 100% shows in outllok for me.

    oh sorry this is for outlook so forget this post.
     
  18. Phizz macrumors newbie

    Joined:
    Feb 14, 2008
    #18
    @Polancito

    I think your solution is for a related but essentially different problem, as I don't see how playing with the settings on my iPhone is going to get iCal to talk to the iSync database correctly on my Mac. I was having the sync problem before I even set MobileMe up on my iPhone.
     
  19. danielforman thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #19
    Yeah as Phizz says the problem is related to Mobile Me sync on the Mac. iPhone is working fine plus I have been changing between my iPhone 1st gen and 3G as my 3G has been replaced a few times due to problems like cracked casing.

    I have been in contact with Mobile Me support and have been trying numerous things to try and sort the problem out, but no luck. So it has now been passed on to a Mobile Me engineer and I am waiting a reply.

    Looking at my console logs when a Mobile Me sync is executed there are errors with the iCal External Sync. Thanks to anyone who has suggested possible solutions and if I get a fix I will post it up here.
     
  20. Maceddy macrumors newbie

    Joined:
    Dec 28, 2003
    Location:
    Australia / Indonesia
    #20
    Same problem. Mail works OK though I don't use it much, Everything syncs fine on my Mac and on my iPhone but all the Calenders on MobileMe website are out of whack. Strange problem everything is OK this end. If I am out and add something to Calender in my iPhone when I come home it's always updated in Calenders on my Mac and Visa Versa but the webpage is always wrong, some events missing, some events different times etc etc.
    Then yesterday all was OK after I went through all the steps ie. unregitsered my computer, deleted all Calenders from MobileMe deleted Mpbile Me Account from iPhone then set it all up afresh.
    Today
    Agrrr Bloody thing is still out of whack.
    I don't understand. My iPhone syncs through MobileMe from my Mac and visa versa all calenders correct etc etc but the web calender on MobileMe is stuffed. Some regular repeating events are missing and from next week onwards every event is timed an hour earlier.

    One would imagine that the iPhone calender and the Mac calender would mismatch or have errors because they sync through MobileMe but they are OK it must be something on their server or in the wbpage code itself.
     
  21. SASDALLAS macrumors newbie

    Joined:
    Sep 26, 2008
    #21
    I'm also pulling (the little bit I have left) my hair out trying to get MM and iCal to play nicely together. I have experienced most of the issues described here so I won't repeat them. But.

    Can someone just give me a "correct roadmap" to make my setup as simple and useful as possible?

    I have:
    1. Mac Desktop
    2. Mac Laptop
    3. iPhone
    4. MobileMe

    All I want to do is be able to enter info on whichever of the above four are handy and make them all make nice to each other.

    So, (???) which direction to I sync both computers? I have tried many combos, hoping that when the sych "merge" option pops up it will "just work" but it does not.

    I won't bother with all the "errors messages, etc." as it seems you all here have had them as well.

    So, I guess to keep it simple, can someone just point out the "sync direction" (on the computers) to make the four items sync correctly. Maybe I'm just not doing that right the first time (????) causing myself more grief.

    TIA,

    SAS
     
  22. Sakshale macrumors newbie

    Joined:
    Oct 1, 2008
    #22
    Me To

    Just another "Me To" note.

    Two iMacs, one MacBook, one MacBookPro, one iPhone 3G and MobileMe. Calendar synchronization simply is inconsistent and unreliable. Currently one MacBook appears to be working and the MacBookPro has a BLANK calendar!

    None of the published fixes appear to help.

    I added an event on the MacBook. It showed up on MobileMe and the iPhone. It has not shown up on the iMac or the "blank" MacBookPro.
     
  23. davidforde macrumors newbie

    Joined:
    Oct 9, 2008
    #23
    Same As

    I have the same problem and it is very frustrating.
    I can enter events to ical and they will sync up to mobile me calendar no problem.
    I can edit the data on mobile me calendar and create new events. When I sync to my Macbook the edits/New events will not show up in iCal.....

    Must say i feel a lot better knowing I'm not the only one with the problem..

    Hope a fix comes before my Trial runs out. I will not pay for something that does not work..
     
  24. davidforde macrumors newbie

    Joined:
    Oct 9, 2008
    #24
    Fix

    Hi All,
    I was having the same problem as you and mobile me support fixed it for me...

    The support guy told me to:
    You should reset sync data on your computer from MobileMe first. Then try adding changes and see if they sync for you.

    To reset sync data open up System Preferences, click on the MobileMe icon, click on the Sync tab, then click the Advanced button. Select the option to reset sync data, and make sure the arrows point to your computer from MobileMe.


    Honestly I did not think it would work, I was convinced it was an iCal bug but it did work.
    I was sure I tried this before.
    I know I definitely tried it with the arrow pointing to mobile me from the computer...

    Anyway mine works now..

    It's worth a try

    Let me know how it goes
     
  25. danielforman thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #25
    Yeah unfortunately I have tried all this. First i did it myself and then followed the instructions the Mobile Me support team have sent me but no joy. I am currently waiting for a reply from Mobile Me support as the engineers are now looking into this problem. I have sent them some data from tests I have run to help them correct the problem. So just got to wait. But good to know you got yours sorted out.
     

Share This Page