Mobile me is just getting worse!

Discussion in 'Mac Apps and Mac App Store' started by k2k koos, Mar 14, 2011.

  1. k2k koos macrumors 6502a

    k2k koos

    Joined:
    Jan 21, 2003
    Location:
    Somewhere between yesterday and tomorrow
    #1
    I just got this message from Mobile me. I run 10.4.11 Tiger, and have a first generation iPod Touch that can't run 4.0 or higher, and have no money to upgrade either. One week ago I've just paid and renewed my mobile me member ship and now I get the below, does this mean I can't use my calendars as I've used to anymore, and paid for the pleasure???

    "Upgrade to the new MobileMe Calendar by May 5, 2011


    Dear MobileMe member:

    On May 5, 2011, MobileMe will transition completely to the new Calendar service that we launched in October. The new MobileMe Calendar includes calendar sharing, invitations, and a new Calendar web application. To maintain calendar syncing between your devices and to continue accessing your calendar at me.com, you must upgrade to the new Calendar by May 5, 2011. Please follow these instructions to complete the upgrade:

    1) Make sure you are using the most recent software on your devices and computers:

    iPhone, iPad, and iPod touch
    iOS 4.2.1 or later

    Mac
    Mac OS X v10.6.6 Snow Leopard
    Mac OS X v10.5 Leopard (requires manual setup)

    PC
    MobileMe Control Panel version 1.6.5

    2) Sign in to www.me.com/calendar and follow the dialog that appears or click "Upgrade now" in the sidebar.

    For more information on the new MobileMe Calendar and this transition, please read this FAQ. If you need help upgrading, go to the MobileMe Support page. Click on "New MobileMe Calendar" and select "Getting started with the new MobileMe Calendar." Choose a support article or click the button at the bottom of the page to get help from a support agent.

    Sincerely,

    The MobileMe Team"
     
  2. wd89 macrumors member

    Joined:
    Sep 2, 2010
    #2
    This is why I won't be renewing my subscription. I too have a 1st gen iPod touch that works perfectly but from May my calendar won't sync because I can't put iOS 4.0+ on the device. I paid £59 in August 2010 for my mail, contacts and calendars to stay in sync with my computer and iPod and out of nowhere they say that from May 2011 I need to upgrade my iPod or I won't get what I paid for.

    People here will no doubt tell us to just upgrade but at the time the 1st gen iPod touch cost over £300 which is not cheap and I don't believe in upgrading just because something is "improved" - my iPod still works like it did the day I got it!
     

Share This Page