Mobile Substrate failure... Common problem?

Discussion in 'Jailbreaks and iOS Hacks' started by Knowlege Bomb, Dec 14, 2008.

  1. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #1
    This happened to me four or five times yesterday. I was using native apps (phone, SMS) when I noticed my clock had been replaced by "Safe Mode". Upon exiting the app I got a popup saying I was operating in safemode because there was a mobile substrate failure and the springboard had crashed. The springboard was grey behind the icons but all the icons worked normally. There was a lot more in the popup but basically I had to respring to get things back to normal.

    Has this happened to you? I did my jailbreak with my Mac this time but other than that nothing has changed from any other time I've done it. I restored last night because it was starting to get annoying. Guess if I decide to JB again I'll be getting out the ol lappy.
     
  2. Bear Hunter macrumors 6502a

    Bear Hunter

    Joined:
    Aug 10, 2008
    #2
    Uninstall SBSettings and see if that fixes it
     
  3. bradenwh macrumors 6502

    Joined:
    Apr 12, 2008
    #3
    Mobile Substrate Safe Mode just happens when the SpringBoard gets overloaded with extensions. Mobile Substrate, in order to prevent other bad things from happening when SpringBoard crashes, uses Safe Mode. It's perfectly harmless.

    But probably something you recently installed that uses Mobile Substrate is causing the problem.
     

Share This Page