MobileMe and iPhone Problem

SpaceKitty

macrumors 68040
Original poster
Nov 9, 2008
3,204
1
Fort Collins Colorado
If I read an email on my iPhone, it gets marked as read one second after I read it on my MBP.

When I read the emails on my MBP or iMac, they don't get marked as read till I open the mail app on my iPhone.

It never used to be like this until about a month ago. Anyone know what I can do to fix this? Restoring doesn't fix it. Same problem exists on all three of my iPhones.

Thanks
 

boatski

macrumors regular
Oct 16, 2008
200
0
this is happening to me as well. for the last 2 days emails aren't even being pushed to my phone, i have to open the app to check for emails.
 
Comment

SpaceKitty

macrumors 68040
Original poster
Nov 9, 2008
3,204
1
Fort Collins Colorado
I just setup a trial account on MobileMe and have the same exact problems. Emails read on iPhone get marked read on MoBileMe immediately. Emails read on Mac or in MobileMe don't get marked read until a new email comes in.Sometimes I read an email on my phone and a few minutes later it shows as new again.

I think we are not getting any other responses here because it is happening to everyone and they think it is normal.
 
Comment

run-kmc

macrumors member
Aug 11, 2009
69
0
I didn't reply because it's not actually happening to me.

:D

Not sure what to tell you, other than it's not happening to everyone.
 
Comment

RandomKamikaze

macrumors 6502a
Jan 8, 2009
884
45
UK
Yeah, it is happening to me as well.

At first I didn't care that much, but now it is getting annoying
 
Comment

SpaceKitty

macrumors 68040
Original poster
Nov 9, 2008
3,204
1
Fort Collins Colorado
Yeah, it is happening to me as well.

At first I didn't care that much, but now it is getting annoying
Thanks for the reply. I contacted MobileMe online support a few nights ago and told the tech that I had the same problem on three different iPhones and on three different MobileMe accounts and he said that it was strange to see it on every account I had.

He had no fix other than to try and restore the phones as new and I told him I tried that multiple times on all three iPhone and the problem remained. He then told me to call iPhone support. Not sure they could help either since it happens on all three of my iPhones no matter what firmware they are running.
 
Comment

RandomKamikaze

macrumors 6502a
Jan 8, 2009
884
45
UK
Thanks for the reply. I contacted MobileMe online support a few nights ago and told the tech that I had the same problem on three different iPhones and on three different MobileMe accounts and he said that it was strange to see it on every account I had.

He had no fix other than to try and restore the phones as new and I told him I tried that multiple times on all three iPhone and the problem remained. He then told me to call iPhone support. Not sure they could help either since it happens on all three of my iPhones no matter what firmware they are running.
Sounds like they haven't got a clue then! Excellent.

I don't want to restore and setup as new, so I guess I will just live with it ;)

Cheers for contacting support
 
Comment

SpaceKitty

macrumors 68040
Original poster
Nov 9, 2008
3,204
1
Fort Collins Colorado
It looks like all push functions are broken between MobileMe/iPhones/computers. I made three contacts on my MBP and usually they would get pushed to the phones within a minute. It's been 45 minutes and still nothing. I think this may be worth canceling over.
 
Comment

RandomKamikaze

macrumors 6502a
Jan 8, 2009
884
45
UK
It looks like all push functions are broken between MobileMe/iPhones/computers. I made three contacts on my MBP and usually they would get pushed to the phones within a minute. It's been 45 minutes and still nothing. I think this may be worth canceling over.
I made a calendar appointment earlier on my iPhone that has been pushed to the MobileMe Calendar page, so that seems to be working for me
 
Comment

Gav2k

macrumors G3
Jul 24, 2009
9,217
1,606
I'm in the uk too and have no issues with data being pushed either way.
 
Comment

RandomKamikaze

macrumors 6502a
Jan 8, 2009
884
45
UK
I'm in the uk too and have no issues with data being pushed either way.
So when you say not a problem either way, if you get an email to your MobileMe account, which then gets pushed to your phone, if you then read it on your Mac or the web page does the message get marked as read without having to go into Mail.app and syncing?
 
Comment

SpaceKitty

macrumors 68040
Original poster
Nov 9, 2008
3,204
1
Fort Collins Colorado
I made a calendar appointment earlier on my iPhone that has been pushed to the MobileMe Calendar page, so that seems to be working for me
After my post above, I realized that push contacts and calendars are working, sometimes it's just a little slow.

My only problem remains when reading an email on my Mac, it doesn't get marked as read on my iPhone until I open the mail app or another email comes in before I open the mail app.

Again this happens on all three of our iPhones all with legit iPhone plans with iPhone data plans.
 
Comment

UngratefulNinja

macrumors 68000
May 9, 2009
1,606
0
Pennsylvania
^^ There have been posts about this before. For some odd reason, Apple/MobileMe says this is the way it's supposed to work. I'll try to find the thread and link it here.
 
Comment

SpaceKitty

macrumors 68040
Original poster
Nov 9, 2008
3,204
1
Fort Collins Colorado
I have asked about this before on here and have also been told that, for some strange reason, this is how its supposed to work
This is not the way it has always been. Way back when they started the whole MobileMe iPhone/push thing, it worked perfectly. Emails read on the Mac got marked as read on the iPhone within a few seconds. They were marked read on all three of our iPhones back then. Also reading an email on one iPhone marks the email as read on the Mac but not on the other iPhones.

It used to work correctly.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.