MobileMe email read/unread status not syncing?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by ncsmith4, Aug 3, 2008.

  1. ncsmith4 macrumors 6502

    Joined:
    Jul 15, 2007
    #1
    Does anyone know why my MobileMe email read/unread status would not sync from my iPhone over to the MacBook Pro Mail.app program? Its pretty annoying...
     
  2. benmrii macrumors 65816

    benmrii

    Joined:
    Nov 14, 2007
    Location:
    NC
    #2
    It's a known issue. Same deal with Mail app to the web. Hopefully it will be resolved soon.
     
  3. ncsmith4 thread starter macrumors 6502

    Joined:
    Jul 15, 2007
  4. ifonline macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Braselton, Georgia
    #4
    This is absolutely driving me nuts. I called Apple and was told this was a known issue and that they are working on it, but I can't help but feel as if this really isn't a priority for them. I hope I'm wrong.
     
  5. WHM macrumors regular

    Joined:
    Feb 5, 2008
    Location:
    South
    #5
    I have almost had enough!! My MobileMe was working fine from day 1... now off and on I am not getting my mail on the iphone and they eventually show up on my desktop and laptop but seems there is a problem now??? Anybody else having this problem?
     
  6. MBHockey macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #6
    Also experiencing the unread/read problem...quite annoying. This is IMAP, right?

    Apple needs to get on this.
     
  7. bbotte macrumors 65816

    bbotte

    Joined:
    Feb 11, 2008
    Location:
    USA
    #7
    If I delete my e-mail on the phone, all those e-mails I deleted on the phone still show in my inbox on the Web application. Even days after I deleted them so the 15 min thing is not an excuse.
     
  8. ifonline macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Braselton, Georgia
    #8
    Mine is not that bad, but it still doesn't work properly. I noticed that prior to MobileMe, deleting e-mail on the iPhone would refresh in Mail.app if I checked for new mail. However, now (after MobileMe implementation), checking for new mail does nothing (unless there is new mail) to refresh read/delete status.

    I did notice though that if I delete multiple e-mails on the iPhone, and then delete one of those e-mails in Mail.app, all the rest that should be deleted will disappear. I also noticed that if I close and then re-open Mail.app, status is properly updated. Finally, if I do nothing, within 30 minutes or so, everything is back in sync. However, the process starts all over again with the next round of read/deleted e-mails.

    I sure hope they get this working soon. It's not the end of the world, granted, but it is frustrating nonetheless. I switched from POP3 to IMAP to avoid having to manage my e-mail like this. Argh...
     
  9. aphexii macrumors 6502

    Joined:
    Feb 22, 2006
    #9
    Unfortunately since Apple released a support article about the issue, I'm thinking it sadly might be "as designed' and not a bug afterall :(

    http://support.apple.com/kb/TS1795

    Thats my exact problem: Lets say I check 3 new e-mails on my computer, when I pick up my iPhone 5 hours later, if I didn't receive any new e-mail since that time, my iPhone will STILL show 3 unread e-mails. Only when I enter the app and it fetches from the server will it update.

    I think the issue lies in the fact that the read/unread status is not push, its pull only. The only way to solve it right now is to set Mobile Me to Push AND Pull, which is BS.

    So far Mobile Me feels like a poorly implemented hodgepodge of IMAP & Push, and sadly I'm very disappointed.
     
  10. ifonline macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Braselton, Georgia
    #10
    This is absolutely not the case here, though, at least for me. Mail.app doesn't update status, even when I explicitly direct it to do so. That is the issue. I have my iPhone set to check for mail every 15 minutes. Not worried about the iPhone. Worried about MobileMe not passing along the status of messages to Mail.app. MobileMe is still broken, and this was acknowledged by Apple tech support when I called them about it.
     
  11. jaked.902 macrumors newbie

    Joined:
    Feb 21, 2009
    #11
    One year later ... No fix yet

    Well, one year later, and Im still experiencing the problem as described. Read/deleted/moved messages do not sync to iPhone unless I "fetch" and not to computer unless I quit and restart Mail.app. Funny thing is I never noticed this happening with iPhone os 2.x. Now that there's support for MS Exchange, they'll probably never fix this. I'm sad to see Apple succumb to Microsoft on this front though.
     
  12. QCassidy352 macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #12
    Yup, I still have this too. Frustrating. Mail is the worst part of mm - the rest works pretty darn well. Dunno why they can't get such a simple thing like the email to work as well.
     
  13. karaho macrumors newbie

    Joined:
    Jan 12, 2009
    #13
    Read/unread

    If I went to pref menu/general of Mail and switch - Dock unread count to All mailboxes and back to Inbox, quit and run Mail again, everything synced fine again.
    Maybe also helps, switch Mobile sync ON/OFF ni System prefs which I did before.
     
  14. mrblack927 macrumors 6502a

    mrblack927

    Joined:
    Aug 19, 2008
    #14
    Annnddd... another year later and it still isn't fixed.

    I don't know why Apple can't handle this. Someone else mentioned that blackberrys can do it because BB uses a proprietary mail server or something. Well... MobileMe is Apple's own mail service. Write some damn custom software and get on with it.

    Sorry, frustrated:eek:
     
  15. SBacklin macrumors member

    Joined:
    Feb 13, 2011
    Location:
    Seattle, WA
    #15
    Fast forward a few months and still not fixed. This is my biggest sticking point with MM. What is even more irritating is that with the transition to iCloud, Apple has an opportunity here to fix this and we as consumers cannot find out if it will indeed be addressed with iCloud or not.

    This sticking point will be a deal breaker for me. If Apple does not address with iCloud, I will move my email services back to my own domain with Hosted Exchange.
     
  16. philbosh macrumors newbie

    Joined:
    Nov 10, 2009
    Location:
    Melbourne Australia
    #16
    Solved... well in part

    Turn off push. It seemed to solve the problem but now I have no push. Anyways I'd rather proper IMAP function and no push imo.

    for noobs: settings/mail, contacts, calendars/fetch new data/push 'OFF'

    BTW: I had an original .mac account and am wondering if everyone who is experiencing this problem had a .mac account coz i know people who have newer mobileme accounts only and they dont have the problem.
     

Share This Page